We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

unknowns in boot up

doncee
doncee asked
on
Medium Priority
152 Views
Last Modified: 2013-12-16
When booting up, I get a message "unable to find 'gckernel.vxd' which is referenced in the windows ini files or in the registry"  (there are 2 files referrenced: the other is 'SWFFCOM.VxD')  Says if I want to use these programs, I must reload them.  
QUESTION??   How do I remove these files so that the boot up is not interrupted?  I have no idea of the programs to which they refer.
Comment
Watch Question

Which program have you recently deleted yourself/uninstalled. I think you should reinstall them and then uninstall so they may take these entries with them . Another method is to see in system.ini and delete references to these files.

Commented:
doncee,

If you want to remove these errors you are going to have to run regedit and goto the following key and remove the 2 entrys
gckernel.vxd SWFFCOM.VxD. You can run regedit by going to start and then run and type regedit

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\InstalledFiles

goto the following key and remove the 2 entrys by clicking on one of them and then right clicking on it and goto delete, it will prompt you to delete, answer yes for both entrys and then reboot your system and see if the errors still appear.

You do not have to worry about doing this as the files are not loading anyway or working.

Good Luck

Author

Commented:
The files are not listed in the path shown in Wayneb's answer. To Varun:  I don't have any idea of the programs from whence these came. I recently revamped my hard drive to get more space and removed several programs of dubious origin.  Thanks anyway.

Author

Commented:
The files are not listed in the path shown in Wayneb's answer. To Varun:  I don't have any idea of the programs from whence these came. I recently revamped my hard drive to get more space and removed several programs of dubious origin.  Thanks anyway.

Commented:
If not in the registry then they must be in system.ini, have a look there.  Most Vxds are loaded via the registry where I pointed you to, but some are loaded via the system.ini
goto start and then run and type sysedit and examine the system.ini file for the files in ?

Commented:
Have you already cleaned up your config.sys and autoexec.bat so that you know there are no old "deleted" programs referenced it them?

Commented:
Don,

   Look for anything with 'gckernel.vxd' in your sysedit files.  If it is in autoexec or config put a REM in front of it to render it null.  If it is in any other file (ie win.ini) put a ; to disable it.  Reboot your computer and the error messages should be gone.  If not, you might have a rogue program loading in your startup folder--check it out.  If not, then your problem lies within the registry.  Do a search for the file in there and delete them.

Commented:
Would norton utilities be any good here as that cleans up registries?

Commented:
Would norton utilities be any good here as that cleans up registries?

Author

Commented:
I have truly searched the 'regedit' and 'sysedit' files several times. as yet, I haven't found any file reference to these 2 *.vxd listings. I followed the string laid out in the registry to no avail. Same in system.ini  BUT, I am not giving up <yet>, Is there a way to delete the registry and have Win95 create it again?
Again, thanks to all for the efforts.

Commented:
Doncee,

  If you have ER disks, yes.  Just boot with em and do a repair of the registry.

Commented:
Use the "find" in regedit to find and remove references to the offending files.
To be safe, save a copy of system.dat and user.dat before deleting anything with regedit

Commented:

Since you removed some software there may be registry entries left over.
You should be able to go back to your system.1st file should be located in the root folder.
You will need to attrib -r -s -h system.1st and system.dat in the windows folder then rename system.dat (your old registry file) then copy system.1st to system.dat in the windows folder.

restart your machine.

If this works you will need to reinstall all of your software so it will be entered in the registry correctly. Be sure to make a copy of system.dat in the windows folder just in case you want to go back.

Godd luck

Author

Commented:
First, I am unable to locate "system.1st" or "system.dat" on my CPU. I used the 'find' function to be sure.
Second, if I had located either or both, I am not experienced enough to understand the "need to attribute -r -s -h systme.1st..." instructions.
BUT, again I do appreciate the effort all are making to help me.

Commented:
Make sure that you are searching (C:) when you do a "Find"
You DO have system.dat on your system in the Windows directory. System.dat and user.dat are NOT optional
Save a copy of these two files into a temporary file, then run regedit and search for the files that are showing up as boot errors as I said above. Removing these strings will solve your problem.

These files are hidden and will not appear in Find, unless you
change file seeing option to display all files.

Author

Commented:
Can you believe? I downloaded and ran "regclean". Still got the same danged file references at bootup. Am going back to retry the above suggestions. Whew    :)
follow these instructions and you should be fine:
1. go to start>programs>MS DOS prompt
2. place a disk in your a: drive
3. type the following commands:
cd \windows
copy user.dat a:
copy system.dat a:
copy *.ini a:
cd\
copy autoexec.bat a:
copy config.sys a:

4. type "exit" without the quotation marks at the c:\ prompt
5. go to start>run and type regedit and then press enter
6. press control+f and type in the exact name of one of the vxd files that you are having problems with.
7. any keys, values or things of the like found in the registry with a matching name delete with the delete key
8. press f3 to continue to find more references of the file until you are completely done searching for that file and deleting all of its instances
9. go to the top of the registry and repeat all steps 6-8 for each of the remaining vxd files
10. close regedit (alt+f4 or registry>exit)
11. go to start>run and type "sysedit"
12. use the search>find option and select the name of one of the vxd files and switch between system files looking for it... any lines containing the vxd file type REM in front of or a semicolon ";".
13. continue #12 on all the system files for all of the vxd file names
14. go to file>exit and tell it to save all changes when it asks.
15. reboot your computer and all of your problems should be solved

If they are not solved boot the computer into dos mode (press f8 when it says starting win95 and it is a choice) and type the following commands:

cd\
path c:\windows\command
cd windows
attrib *.dat -s -h -r
copy a:\user.dat
copy a:\system.dat
attrib user.dat +s +h +r
attrib system.dat +s +h +r
copy a:\*.ini
cd\
copy a:\config.sys
copy a:\autoexec.bat

That should either fix your problem or return you to your current status if my solution does not work... the saving and copying of the files is not necesary but i would do it in case the solution does not work you can at least bring it back to square one even though I am confident it willl solve your problem



Author

Commented:
Already solved for me by Goliath.. my prev message asked how I can get the points to him as I missed the ppoint of his answer when I first read it..
Khemicals' answer may have worked, but the prob was already handled.
Thanks again to all..
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.