• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 189
  • Last Modified:

Indexes not showing in Enterprise Mgr

After creating INDEXES in the INDEXES function screen, the indexed fields are not marked when I click on the TABLE name and the schema comes up showing the table structure. What gives?
0
rdoty
Asked:
rdoty
  • 4
  • 3
  • 3
1 Solution
 
mkmccrearyCommented:
After you created the indexes, did you do a refresh on the table views to requery the system tables.  That may fix you problem.


0
 
rdotyAuthor Commented:
Yes, I performed a "refresh" and the table key check marks that should show next to my indexed fields are not there.
0
 
mkmccrearyCommented:
Are you actually defining some of your indexes as primary keys?
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
mayhewCommented:
That table schema screen does not show an index unless it's defined as a primary or foreign key.

To see indexes you need to look at that 'manage indexes' screen.  As a shorcut, you can right click on the table and select that screen off of the popup menu.

Hope that's helpful!

Don
0
 
rdotyAuthor Commented:
The mentioned indexes that do not show in the table schema view, are mostly PRIMARY KEYS, and some are COMPOSITE CLUSTERED PRIMARY keys, and even some are FOREIGN KEYS. However, none of these show.
0
 
mayhewCommented:
Interesting.

Why don't you reject my answer and I'll look into it some more.  :)

Don
0
 
mkmccrearyCommented:
I think I have it.  If you are using the Indexes... Screen that comes up when you right click on a table,  or the menu item Manage - Indexes then you cannot specify whether the index is a primary or foreign key.  You need to perform this from the Table Schema screen using the Advanced properties button (which looks like a table with a plus sign.)  You can use the Advanced properties to set Primary Keys, Foreign Keys, Check Constraints, and Unique Constraints.  You will have to drop any clustered indexes you have created without using the Advanced Properties button if you want to use clustered indexes as primary keys.  The other option is to SQL and the Alter Table statement.  Also remember that a field cannot allow nulls and be a primary key.  If you have any more questions just drop a comment.

Later,
Martin

0
 
rdotyAuthor Commented:
You are correct. Mayhew was close, but did not tie the actual definition of the separate functions into two separate actions.
Thanks a Lot!

0
 
mkmccrearyCommented:
Glad I could help.  I could use the points, a friend is giving me a hard time about my point challenged.

Later,
Martin

0
 
mayhewCommented:
Good anser, mkmccreary!

I'm glad you got it figured out!   :)

Don
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now