Solved

Creating .rtf files

Posted on 1998-08-29
12
229 Views
Last Modified: 2013-12-28
When I create a new file in Wordpad, it is a Word .doc file.
  Here is what I want to accomplish.
  In Wordpad, I want the new files to be .rtf files.
   In MS Word, I want new files to be .doc  but with the option of creating .rtf files whenever I want.
   Probably some combination of files associations, and TweakUI tricks should be able to accomplish this.
(Right now on the context right-click menu, New files include Word .doc and .txt files.)
0
Comment
Question by:cma
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 7

Expert Comment

by:dankh
ID: 1644400
CMA,

   Changing the default file save in Word is easy: go to tools/options/save and select your format.  As for giving you the option to save in different formats, select the 'save as' button and it will allow you to amend the format for word docs there.  Changing wordpad's default save may prove difficult.  however, you can select to 'save as' in Wordpad as in word and select the docs you mention of.
0
 

Author Comment

by:cma
ID: 1644401
dankh has solved first half of question and should get 100 points.  
  I can now open Word files as .rtf by default.

 Now what I want to be able to do is open or create .rtf files by default with Wordpad, not Word. (When I open an .rtf file, Word opens it. Although if I first start Wordpad, then use Newfile, it will be an .rtf file.)
I think I need to add  some key to the registry under .rtf but I am not sure.
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644402
CMA,

  If i understand the latter part of your comment correctly, you can have Wordpad open RTF files by default.  Go to Explorer/view/options/File Types and find 'Rich Text Format.'  From there, you should be able to edit which program to use when you open up a RTF file.  If this works, tell me to post an answer.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 7

Expert Comment

by:dankh
ID: 1644403
CMA,

   One more suggestion:

Once you instruct the computer to use WordPad to handle RTF files, you can create a shortcut to a xxx.rtf file and that will open up WordPad with a .rtf extension.  That is, create a blank .rtf file (name it something like default.rtf) and click on that to use WordPad.  When you save data written to that default RTF, all you need to do is hit save and rename the file and it will be saved in RTF format.  You can reuse the default.rtf indefinitely.
0
 

Author Comment

by:cma
ID: 1644404
We have made more progress. When I open an .rtf file, it opens with Wordpad by default. However, I always get an error message:
"Cannot find file 'C:\WordpadFiles\default.rtf' (or one of its components). Make sure path and filename are correct...'
    Or if I try to open another .rtf file, it does open, but get same error message but with the file name instead of "default.rtf".
   How to get rid of the error message? Perhaps the registry expects .rtf files to be somewhere else?

0
 
LVL 7

Expert Comment

by:dankh
ID: 1644405
CMA,

   You probably altered the default.rtf file (renamed it or something).  Try this, delete the original default.rtf file and create a new one.  On this new one, right click it and bring up the properties box.  Check the 'read only' box.  This will protect the original from changes.  Give it a try and tell me how this works.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1644406
Wordpad is fairly "dumb"; it's quite possible that there is no way to tell it to create a RTF file.
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644407
CMA,

   I think you will have to instruct it manually to save as a RTF file.  Wordpad defaults to .doc and i think the only way to change that is to alter its code.  
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644408
CMA,

   However, with the prescribed method above, you can kinda fool Wordpad into saving all docs into .rtf format.
0
 

Author Comment

by:cma
ID: 1644409
Didn't work but thanks for good asssistance.dnakh should get 200  points.
0
 
LVL 7

Accepted Solution

by:
dankh earned 200 total points
ID: 1644410
Cma,

   Here is the post to reward me the points.  Thanks.  I guess anyone who accesses this question can read the remarks.
0
 

Author Comment

by:cma
ID: 1644411
I finally found the solution to get rid of the error message.
 In wordpad, can tell wordpad to make .rtf files the default editor.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Determining the an SCCM package name from the Package ID
Configuring Remote Assistance for use with SCCM
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question