Linux bootdisk/kernel that works with the Asus P2B-S?


I bought the Slackware 3.5 distribution recently only to find that neither the 2x4x nor the scsi bootdisks seem to be able to find my SCSI hard drive on my system.  My motherboard is an Asus P2B-S, with an onboard (built-in) SCSI controller (AIC-7890, I think).  Setup's fdisk always complains about "cannot find /dev/sda".  I'm guessing that it isn't finding or recognizing my SCSI controller.

If this is the case, then I'd like to know:

1.  Where can I get a bootdisk that does recognize such a controller (so that I can at least install Linux on my system, for starters :)

2.  Where can I get the kernel source that has this support available (so that I can recompile it for support with other devices, in addition to the SCSI controller).


Thanks!


AP9
ap9Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bentenCommented:
Standard kernels can be found at:

http://www.kernel.org/

I believe Redhat has a bootdisk for that chip but I do not think this will help with a Slackware 3.5 distribution.
0
JYoungmanCommented:
See if you can boot the RH 5.1 boot disk:-

ftp://ftp.redhat.com/pub/redhat/redhat-5.1/i386/images/boot.img


0
pestilenceCommented:
Your scsi controller isn't supported you have to either ask your motherboards company to do something about it, or try to search if there is a kernel (hacked) which supports your scsi controller..
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jeffa072897Commented:
If you're chip set is a genuine Adaptec chip set try calling Adaptec.
They offer full support for Linux now. Perhaps they cah point you to a
driver/kernel.

Also, from you question text I think you did this but if not - try the Adaptec 27xx
boot disk. It's pretty generic in it's AIC78xx chip set handeling.

Also, have you tried specifing the I/O address of the controller at Slackware boot
prompt? You should be able to get this address from the controller setup BIOS.

Be prepared though, it may not be supported.........yet.


0
ap9Author Commented:
Jeffa -- hey, thanks for the comments!  I did not know that Adaptec supported Linux now.  Cool!  I don't remember if I tried the 27xx boot disk.  I tried scsi and the adaptec29xx bootdisks (the text file said that worked with the AIC78xx stuff) but do not recall seeing one for 27xx -- I'll look again.  Thank you!


ap9
0
jeffa072897Commented:
Do you want to consider this closed?
If no that's o.k. by me.
If you do, post a commant and I'll reply as an answer so the question
will close here.


0
ap9Author Commented:
Well, I looked on the CD and could not find an bootdisk image that went by 27xx.  The only specific adaptec one I could find was the aha2x4x.s (well, also the older 1740, etc), which I've already tried.  :(

Any other ideas?


Thanks,

ap9
0
ap9Author Commented:
Jeffa -- actually, reading the description for the aha2x4x.s bootdisk, it seems to be able to work with onboard Adaptec controllers, too.  However, I can't seem to pass it the parameters to force it to find it.  If you can tell me the how to pass it the parameters, I'll consider the question closed.

I've tried, at the LILO prompt from the bootdisk:

ramdisk aha2x4x=0xd000h,12,7,reconnect

where the format is base IO,IRQ,ID,reconnect (or should reconnect be something else?).  That is what I garnered from the BOOTING.TXT file.

Thanks,

ap9
0
jeffa072897Commented:
Hmmmm.........let me think for a few hours.
Do you get any prompt like "Press Control A" for the scsi bios?
Adaptec cards do this and many of the onboards as well.
If you do, look in the controller settings section for enable/disable plug and play.
If/when you shut off plug and play you shopuld get a box to set the I/O and IRQ.
WHen the machine boots do you see an I/O address flash on the screen from plug
and play?  From your last message I'm guessing that you're seeing D000 for an I/O
address. If not, I think that first parameter is the I/O address and the common one for
Adaptec stuff is 300 or 330 which makes the number 0x300h or 0x330h.
Let me scope the booting.txt and I'll be in touch tomorrow.
0
ap9Author Commented:
Yes -- I went into the SCSI BIOS and got those numbers.  It said the Base I/O was D000H, IRQ 12, and ID 7.  Booting.txt gave the format as device=base io,irq,id,reconnect.  My problem is I'm not sure what to put down for "device" or for "reconnect".  I have been using aha2x4x for device, and just typing in "reconnect" but I think it is probably a value or something.  That's what I need help on I guess.


ap9
0
jeffa072897Commented:
ap9;

What you've got and what you're doing looks 100% right.
Have you tried not using the ramdisk?
The reconnect parameter should match the controller's setup for disconnect/reconnect
enabled. Enabled is the normal default.

BTW, I think I asked this, but when the boot disks boot, does the scsi driver show any
targets? If so, see what designation it's giving them (i.e. sda, sdb, hda, etc.). Make sure
you are using this designation.  Also, if no targets show up during boot fdisk can't work.
 Maybe the way your mother board implements the chip set the drives are coming up
with a different designation.

0
ap9Author Commented:
No targets show up when I boot from the bootdisks.  It says "0 scsi hosts found"  (or "scsi hosts: 0 found").  Something along those lines.

Was I actually supposed to type "reconnect" as part of the parameter?  That is what I've been doing, but I'm thinking maybe it should be 1 or 0, or maybe yes/no, instead.  I'm also not sure if the parameter name is actually aha2x4x, but that's what it seems like from the examples I've read.


ap9
0
jeffa072897Commented:
Well......
The reconnect you could probably leave off, but I'm sure reconnect is correct.
BUT, that's not the problem.
The boot disk isn't seeing your scsi controller at all.
The "0 scsi hosts found" means the scsi driver never found the controller.

If all the Adaptec SCSI boot disks you've tried give you the 0 hosts found then you're in
real deep ____ .

From here there's really only four options
     1) Try Adaptec and see if they have a boot disk(since they support Linux now)
     2) Contact the motherboard manufacturer and see is they have a boot disk (not likely)
     3) Get either an IDE drive and controller or a SCSI card to plug into the system
         (It will work, not elegant and co$t$ more)
     4) Punt.

Sorry to have it come to bad news.
Before anybody tries to slam Linux - yes I've even had something like this happen with the
$^#@ that comes from Redmond too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ap9Author Commented:
Doh, I was afraid of that.  But thanks for giving such a definitely, concrete answer, though.  I appreciate it.  Buying another card isn't really an option (since it defeats the purpose of getting an MB-equipped one to begin with) but I'll definitely check out the other ones.  Thanks again!


Ap9
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.