Modem port open @ Windows98 start up?

I am running Windows98 on a WinBook XLi PentiumII 266MHz 32 Meg Ram 56Kflex LT Win Modem on COM 2.  When I boot my laptop sometimes, but not always the COM 2 port is (open/in use)and no com program is running at the time.  Then when I go to log onto the internet with the Windows DUN it locks up my computer because the modem port COM 2 is in use. I have to reboot and then try to log on to the internet again.

As I stated before there are NO other com programs running at that time.  I only have a "few" programs in the system tray. They are Windows98 System Agent, Norton Anti-virus, Norton Crash Guard, and Norton System Doctor.

I have ALL the latest updates for my computer and have run Norton Win Doctor and all checks 100% ok.

Why does my com port 2 become (open/busy) at windows98 start up?  How can I FORCE it to close and or reset the modem port COM 2?  In the control panel this modem has not reset feature.

Thank you..
Yoy
YoyAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
cantrellConnect With a Mentor Commented:
I had the same problem with my Dell laptop. This is what fixed mine. I went into the bios and disabled an option for the com port advanced power configuration. I forget exactly how it was worded in the bios but basically this feature allows the com port to disable until your using it - supposedly saving power. However, this causes problems sometimes. See if your bios has this feature and if so, disable it.
0
 
pdloveCommented:
I found this problem on one of my desktop machines:

If the laptop is trying to set PNP options, and Windows is too, then the crossed resorces confuse the OS.
OR
If the incorrect drivers are loaded, It will cause that too.
0
 
YoyAuthor Commented:
Answer rejected because pdlove did not give a solution to the problem.  Simply restated that he/she had come upon a similar problem of com ports being busy/in use, yet no corrective solution was offered.  Problem still persists and is open no pun intended to another expert for "solution".
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
pdloveCommented:
Let me rephrase:

Try disabling PNP-BIOS, if possible, or try re-installing the drivers
0
 
pdloveCommented:
Let me rephrase:

Try disabling PNP-BIOS, if possible, or try re-installing the drivers
0
 
dmckee1Commented:
I asume your modem is a card if so try leaving it out when starting the system some modems will try to open the port,.... and as the saying goes hardware is better than software driven any time.....
0
 
YoyAuthor Commented:
WinBook XLi is equiped with an internal Lucent Techonogies LT Win Modem 56Kflex. This machine does not allow or have the option to disable PNP (Plug & Play).  I have deleted the modem and rebooted to let Windows98 "find the modem" and "re-install" the drivers for said modem in an attempt to correct the problem.  So far it seems to be working.  pdlove is runner up for the points ;-)

Thank you all for your help.
Yoy
0
 
dmckee1Commented:
Glad to hear all is well for now ... another option is to check for some other init strings to make sure your modem starts out clean may I recomend k56.com check and see if have any strings for your modem......
0
 
YoyAuthor Commented:
Yes this corrected the problem.  I reinstalled the modem drivers and thought that corrected the problem, but it still persisted. Once I disabled that feature in the bios it stopped completely.
Thank you
0
 
cantrellCommented:
Great! Glad to hear it. I was certainly glad that it fixed mine too. I was pulling my hair out trying to figure this one out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.