Solved

Getting rid of Netscape Login prompt for .asp

Posted on 1998-09-02
5
228 Views
Last Modified: 2013-12-25
I am using an .htm form to prompt a user for info which is then passed to a .asp file to add info to an Access database. Whenever I "submit" the info on the .htm form, Netscape 4.04 prompts me for a userid & password. This does not happen in IE4. What is causing this and how can I stop the dialog from popping up? Also, even if I type any userid & password it is rejected. I am using NT4 workstation.


0
Comment
Question by:englm
5 Comments
 
LVL 10

Expert Comment

by:MasseyM
ID: 1854711
Can you post your code and ASP files?  if it is REAL large, send it to masseym@hotmail.com.

Thanks
0
 

Author Comment

by:englm
ID: 1854712
Here is the .htm file:

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;charset=windows-1252">
<TITLE>info</TITLE>
</HEAD>
<BODY>
<FORM METHOD="POST" ACTION="http://george/aspsamp/advworks/test2.asp"
         ENCTYPE="application/x-www-form-urlencoded">
<TABLE>
<TR>
<TD ALIGN="RIGHT" VALIGN="MIDDLE">Name?
<TD ALIGN="LEFT">
<INPUT TYPE="text" NAME="name" VALUE=""
          SIZE="20" MAXLENGTH="150">
<TR>
<TD ALIGN="RIGHT" VALIGN="MIDDLE">Organization?
<TD ALIGN="LEFT">
<INPUT TYPE="text" NAME="organization" VALUE=""
          SIZE="25" MAXLENGTH="150">
<TR>
<TD ALIGN="RIGHT" VALIGN="MIDDLE">
Email Address?
<TD ALIGN="LEFT">
<INPUT TYPE="text" NAME="email" VALUE=""
          SIZE="25" MAXLENGHT="150">

<TR>
<TD ALIGN="RIGHT" VALIGN="MIDDLE">Phone Number?
<TD ALIGN="LEFT">
<INPUT TYPE="text" NAME="phone" VALUE=""
          SIZE="25" MAXLENGHT="150">

</TABLE>
<INPUT TYPE="reset">
<INPUT TYPE="submit" NAME="submit" VALUE="Submit">
</FORM>


Here is my .asp code:

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html;charset=windows-1252">
<TITLE>info</TITLE>
</HEAD>
<BODY>
<%
Param = Request.QueryString("Param")
Data = Request.QueryString("Data")
%>
<%
If IsObject(Session("test_conn")) Then
    Set conn = Session("test_conn")
Else
    Set conn = Server.CreateObject("ADODB.Connection")
    conn.open "test","admin","admin"
    Set Session("test_conn") = conn
End If
%>
<%
   
    Set rs = Server.CreateObject("ADODB.Recordset")
    rs.Open "info", conn, 1, 3, 2
   
    name=request.form("name")
    organization=request.form("organization")
    email=request.form("email")
    phone=request.form("phone")
          
    rs.AddNew
    rs("name") = name
    rs("organization") = organization
    rs("email") = email
    rs("phone") = phone
   
    rs.Update
    rs.Close
%>



0
 
LVL 28

Expert Comment

by:sybe
ID: 1854713
You have set the webserver (IIS) to Challenge/Respond for the virtual directory. Turn that off.

Challenge/Respond can only be used by IE. It is an authentication method. The server will ask for username/password and the browser will send it encrypted. IE will use the current NT username/password from the machine on which the browser is running.

Netscape does not know what to do with it.


0
 

Author Comment

by:englm
ID: 1854714
Sybe,

I turned off the NT Challenge/Response for my www directories through Inet Service Manger, but the same problem occurs.

I also noticed that in Netscape I cannot type http://myserver/mystuff.htm as I can in IE. When I type this URL into the Netscape box I immediately get a login prompt. Netscape wants to see File://E:/mydirectory/mystuff.htm.
0
 
LVL 1

Accepted Solution

by:
gasim earned 50 total points
ID: 1854715
The user name and password that you should provide is not the Database user.
Instead use a valid user that is allowed to access the IIS.
Your problem is that the IUSR_XXXXX user password in your IIS WWW service and User Manager for domains are not synchronized.
Do the following:
1- Change the IUSR_XXXX password to (whatever) for example.
2- In IIS Admin change the IUSR_XXXX user passord to the same one in step 1.
3- Stop and restart the WWW service.

This shouls at least remove the problem of rejecting provided credentials (supply the IUSR_XXXX and password if the dialog pops up).
Hopefully you wan't face it.
Make sure that Anonymous access is enabled for your WWW service.

0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
CSS: Making responsive table look nicer 7 31
specific navigation button disappears on mobile devices 1 52
Code Manager | Snippits 2 37
PHP Curl to output a url 7 53
Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
Viewers will get an overview of the benefits and risks of using Bitcoin to accept payments. What Bitcoin is: Legality: Risks: Benefits: Which businesses are best suited?: Other things you should know: How to get started:
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question