IIS4 cache

my web site is located on a virtual server running IIS4. on the site, i'm hosting a webcam and a few isapi extensions..

the problem is, the server is set up to cache files.. when, for example, a few people look at the webcam for a few minutes, the picture will hang after a while because the server begins caching it. thus it won't reload the newest picture even though it's reloading..

this caching ALSO causes a problem for my isapi dlls.. apparently, when a dll is loaded on my site, the nt box won't let go of it incase i need to delete/update it..  

i know caching can be turned off on the server, but 1) i don't have access to the server (because again, it's a virtual host and i have no physical contact with the machine) and 2)my provider says the only way they know how to disable the cache is to disable it for the whole machine.. obviously this would slow down the machine considerably..

my question: is there a way to disable the cache for my site only? or is there another way to get around this?
rabbitearsAsked:
Who is Participating?
 
leon321Connect With a Mentor Commented:
The ISAPI DLL should be designed in a manner that the request and respond threads are not cached. If you wan't to reload a page or whatever, and you want to force a reload from the server, you could use a java script command called 'refresh' or 'reload'. If you call it with 'true' as parameter, for instance something.refresh(true) , the document/resource is retrieved from its original location and not from a cached copy.
0
 
sabre2Commented:
As far as I know your out of luck unless you have access to the caching utilities on the server. To adjust cache on the server goto HKEY_LOCAL_MACHINE \current control set \services\inetinfo\parameters\memory cache size

Windows NT and IIS handle Caching in completely different ways.

You could also check how it handles if you change your virtual memory size on your machine.  multiply your physical memory size by 1.5 to get the figure.

0
 
mararCommented:
To disable caching for ISAPI applications, you can disable from the propertie tab of the virtual directory. Tell the provider to do this. On the tab of the properties, it specifies what kind of applications are available and what should be the caching mechanisms for each of them. This can solve your ISAPI dll caching problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.