Free for all links

I got a problem.
I have put together matt's script for free links.
Everything is working fine until i submit the link.
I'm being redirected to links.html page and i refresh but
nothing is displayed. I have chmoded links.pl 755 and
links.html 777. What is the problem ??
roggeAsked:
Who is Participating?
 
John P JohnConnect With a Mentor Advisor ICTCommented:
U need to add this to the beginning of ur links page
This is because script is looking for a start point which is done by the below code. Do use  it and reply back of the same.
SELECT THE BELOW AND PASTE IT TO UR PAGE

<!--begin-->
0
 
martinagCommented:
How if you open links.html in Notepad/VI or any other text editor?
Does it contain anything?

How if you view the source in your browser?
Does it contain anything?

Could you point us to an URL?

Martin
0
 
roggeAuthor Commented:
Yes ..i checked ..  and it contained all the html tags. I even viewd it in cute ftp.
( I do not use Telnet.)
I  tryed a brand new links.html file from matt's .. my old one was slightly modifyed by me ..but it still didn't work.

Sorry i can not piont you to the url right now. I deleted the files but i will have them up and running again tonight.
Rogge
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
martinagCommented:
>> nothing is displayed
Is _nothing_ displayed or is nothing from your new post displayed?

Anyway, I am suspecting that you are missing an ending </TABLE>
Go through links.html and count all the <TABLE> tags.
Then count all the </TABLE> tags.
If you have got less </TABLE> than <TABLE> that is why nothing shows up.

Martin
0
 
roggeAuthor Commented:
I have uploaded links.html again .. a brand new one .. and install it ..
I checked the database.txt after i have submited a link and it has recorded the sumiting ..
but still nothing in links.html
here is the URL., please check yourself.
http://oad.nu/myssilen/link/links.html
Can't it be that it only works in UNIX ??

Roger
 
0
 
martinagCommented:
I tried adding my site and it was added to database.txt alright.

I have checked some "Free for all links" pages around the net and they all looks just like your.

Have you edited the script anything?

Martin
0
 
martinagCommented:
About your UNIX/NT theory...The script can open database.txt so there should not be anything wrong with the system.

Martin
0
 
roggeAuthor Commented:
No ..haven't edit nothing .. either in the pl file or in the html file ..
Yesterday i was in Matt's suport area för Free links and i wasen't the only one with this
problem .. almost eveyone asked this questions ..

I tryed some diffrent approches to ..
chmoded all 777 .. i even chmoded the link cataloge ..
*humm*

Roger
0
 
martinagCommented:
Do you use version 2.2 of the script?
All versions prior to 2.2 aren't NT-compatible.
(Look in your links.pl at the top row for the version number)

Martin
0
 
b2piCommented:
Are you by any chance behind a proxy server with a truly massive
cache? (hint, hint)
0
 
CYOCommented:
did you chmod 777 the directory. I been on many serversand sometimes I have to chmod the directory that I want it to change trying chmod your http://oad.nu/myssilen/link/ directory
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.