Solved

Playing Audio CD's

Posted on 1998-09-03
45
507 Views
Last Modified: 2013-12-28
I can't play Audio CD's in Win 98.  I get sound from all CD's (windows, games etc.) but when I put in a straight Audio CD I get no sound.  The Cd player opens and everything seems to be working but --no sound--.  All other sound works fine.  I have a Sanyo 20X CD and Soundblaster AWE 32.

Can anyone tell me how to play Audio CD's?
0
Comment
Question by:jgsax
45 Comments
 
LVL 7

Expert Comment

by:cmcgee
ID: 1644607
I had the same problem with 98, I had to do this..

Try looking in your Registry for this Key

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\MediaResources\mci\cdaudio

Remove the Volume Settings Entry and then try rebooting
Other CD settings are in -

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\MEDIA\0000\Config

Hope this helps
Craig

0
 
LVL 7

Expert Comment

by:dankh
ID: 1644608
Jg,

   Also, check you volume control and make sure the CD is not on mute.  Sometimes we overlook the most obvious things.  :)
0
 

Author Comment

by:jgsax
ID: 1644609
Appreciate the help Craig but nothing happened.  I did exactly as you suggested and it made absolutely no difference.  Oh, I also checked the volume control and the mute is not checked.  Would have been nice though if that had been the problem.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1644610
Is the cable connection from your CD-Rom to your sound card secure?  It might be loose.
0
 

Author Comment

by:jgsax
ID: 1644611
The cable is secure.  I get sound on all games that are played on the CD  and even the windows CD but music CD's with strictly audio will not play.
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644612
Jg,

  Open up multimedia and play with your midi settings.  That is, make a different selection in the box.  Give it a try.
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644613
Jg,

  Also, give this a shot:

click Start , then Programs, Multimedia and click on Volume Control. Increase the Master volume and CD volume to at least 3/4 the way up, then check the Mute box for both Master and CD. Then uncheck each Mute box and try playing an audio CD.
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644614
Jg,

Open up multimedia and play with your midi settings.  That is, make a different selection in the box.  Give it a try.

Also, give this a shot:

click Start , then Programs, Multimedia and click on Volume Control. Increase the Master volume and CD volume to at least 3/4 the way up, then check the Mute box for both Master and CD. Then uncheck each Mute box and try playing an audio CD.
0
 

Author Comment

by:jgsax
ID: 1644615
Well I played with the volumn controls as suggested.  Still no sound.  Everything else works on the CD player.  I can reject and eject the CD change tracks etc.  I just don't get any sound.

I have games that play entirely on the CD and I get music and voices but I get nothing with a straight audio CD.  Incidently when I went to the volumn control in multimedia, the midi section was dimmed.  Does that mean anything?
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644616
JG,

  Yes, that means something.  You should have Midi selections.  Go to Multimedia/devices and check to see if you have anything installed for the midi.  You should see something from SoundBlaster.  If not, you should uninstall the SoundBlaster and reinstall it.  You need to have something in the midi selection.
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
ID: 1644617
That means it is not a big problem. :)

Double click Speaker icon on the right lower corner on task bar, this pops up the volume control panel, make sure the CD volume control is on the panel and not be mute. If it does not appear at there, open Options menu, choose Properties, check Playback and CD Audio items and return to main interface of Volume Control. That should be OK.
0
 
LVL 7

Expert Comment

by:cmcgee
ID: 1644618
When beta testing 98, this was a frequent issue. All sounds were normal, but CD audio was missing even though the cable was properly attached.
I know that I already posted a comment about the registry, but what values were showing in for the Volume Setting in

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\MediaResources\mci\cdaudio

Craig

0
 

Author Comment

by:jgsax
ID: 1644619
To cmcgee:

In my registry under cdaudio there is "Unit 0"  when I highlight that on the right is "Default" with no values.  When I highlight "cdaudio" on the right is Default, Default Device, Description, Disabled, Driver, & Friendly Name".   I deleted the entry on volumn control as you suggested and like a dummy did not write down the entry.  It was in Unit 0 also.

To bbao:  

There is no Speaker icon on my task bar but I went to volumn control panel from programs and the CD volumn control is on and not mute.  
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
ID: 1644620
What version of Windows 98 are you using? Retail version, OEM version, Final Release, RC4, RC1 or Beta3 even Beta2?
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
ID: 1644621
Did you apply the latest version multimedia update, DirectX 6?
0
 

Author Comment

by:jgsax
ID: 1644622
To Dankh:

I assume you mean in the device manager and I don't have multimedia listed at all.  Creative labs driver are under Sound Video and Game Controllers.  Should I use add programs under contol panel and install the whole multimedia?  Most of them are listed as installed.

To bbao:
I have the win 98 upgrade to Win 95 retail version 4.10.

My Direct X is what came with the win 98 disk so will check on upgrade.

To All:

Thank you very much for helping me so far.


0
 
LVL 7

Expert Comment

by:cmcgee
ID: 1644623
After you deleted the Volume Settings entry, it should of rebuilt the entry upon rebooting.


Here is what the Reg entry should look like

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\MediaResources\mci\cdaudio\unit 0]
"Volume Settings"=hex:00,00,00,00,ff,00,00,00

hope this helps,
Craig
0
 
LVL 1

Expert Comment

by:skatan187
ID: 1644624
Connect your cdrom to you soundblaster !!!
PLAYING CD'S HAS NOTHING TO DO WITH SOFTWARE !!

You can even play a cd without windows,

skatan
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644625
JG,

   Yes, you should have something installed from Creative under multimedia/devices for the midi.  I suggest you uninstall your SoundBlaster completely and reinstall it from scratch.
0
 

Author Comment

by:jgsax
ID: 1644626
Well I've done everything that everyone suggested and still no sound on audio CD's.  

To Dankh:

Windows 98 installed the drivers for soundblaster and I no longer have a SB16 folder.  The last time I tried to install the software for AWE 32 it created a big problem and I had to uninstall win 98 and revert to my old win95 configuration.  I no longer have that option as my original registry got fouled up and I had to delete the old files the last time I installed win 98.  I will check Creative labs to see if they have an updated install file for win 98.
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
ID: 1644627
A Simple Problem, 2 High Points, So Many Posts, Still Do Nothing. :-((

Is there a ear jack on your CD-ROM, try hear from there, to check if it is the CD-ROM problem?

Hope this ... :))))
0
 
LVL 1

Expert Comment

by:jrgaylor
ID: 1644628
Do you have the right file extensions associated with audio cds' and cdplayer.
to find out  in windows explorer click view,folder options,file types, scroll dowm untill you find AUDIOCD and CD AUDIO TRACK make sure they both open with CDPLAYER ( or what ever cd player you are currently using)
0
The problems with reply email signatures

Do you wish that you could place an email signature under a reply? Well, unfortunately, you can't. That great Exchange/Office 365 signature you've created will just appear at the bottom of an email chain. What a pain! Is there really no way to solve this? Well, there might be...

 
LVL 8

Expert Comment

by:wayneb
ID: 1644629
I would give this a shot and remove the codecs and then reinstall them.

How to Install and Remove Codecs and MCI Devices in Windows
Last reviewed: June 23, 1998
Article ID: Q142731

The information in this article applies to:
Microsoft Windows 95
Microsoft Windows 98

SUMMARY
This article describes how to install and remove codecs and Media Control Interface (MCI) devices in Windows.

MORE INFORMATION

Codecs are used to play compressed files by decompressing them in memory. Adding a specific codec lets you play files compressed in that file format. Removing and reinstalling a codec may solve problems playing a particular file type.

MCI devices are drivers that provide Windows-based programs device- independent capabilities for controlling multimedia hardware and software. Removing and reinstalling MCI devices may solve problems playing certain files.

Adding All Default Codecs
To add all the default codecs in Windows, follow these steps:

In Control Panel, double-click Add/Remove Programs.

On the Windows Setup tab, click Multimedia, and then click Details.

Click the Audio Compression and Video Compression check boxes to select them, and then click OK.

Click OK.

Adding a Specific Codec or MCI Device
To add a specific codec or MCI device, follow these steps:


In Control Panel, double-click Add New Hardware.

Click Next, click No, and then click Next.

In the Hardware Types box, click Sound, Video, And Game Controllers.

Click a manufacturer in the Manufacturers box and a model in the Models box, and then click Next.
The following table lists the codecs included with Windows:


      Manufacturer             Model
      ----------------------------------------------------------------
      DSP Group                TrueSpeech Software Audio Codec

      Intel                    Indeo R3.1 Video Codec
                               Indeo R3.2 Video Codec

      Microsoft Audio codecs   ADPCM Audio Codec
                               CCITT G.711 A-Law and u-Law Audio Codec
                               GSM 6.10 Audio Codec
                               IMA ADPCM Audio Codec

      Microsoft Video codecs   RLE Video Codec
                               Video 1 Video Codec

      SuperMatch               Cinepak Video Codec

   NOTE: Microsoft PCM Converter is installed by default.

   For MCI devices, click Microsoft MCI in the Manufacturers box, click
   the model you want in the Models box, and then click Next.

   The following MCI devices are included with Windows:

      CD Audio Device
      MIDI Sequencer Device
      Motion Video Device
      PIONEER LaserDisc Device
      VISCA VCR Device
      Wave Audio Device

   If the codec or MCI device you want to install is not listed, it was
   not installed by Windows. If the codec or MCI device was included
   with another program, reinstall the program to reinstall the codec or
   MCI device. If the codec or MCI device is located on a driver disk,
   click Have Disk and specify the location containing the files. If
   Windows 98 finds a codec or MCI device, click No to add the device to
   the list of installed devices.

   NOTE: Unlike the other MCI devices, the Mixer Device cannot be added
   manually. This device can be added only during the installation of a
   Windows-compatible sound card driver. When it is installing the
   driver, if Windows determines that the driver can support the Mixer
   Device, it installs the Mixer Device along with the sound card driver.


Click the Finish button.

Removing the Default Codecs
To remove the default codecs, follow these steps:


In Control Panel, double-click Add/Remove Programs.

On the Windows Setup tab, click Multimedia, and then click Details.

Click the Audio Compression and Video Compression check boxes to clear them, and then click OK.

Click OK.

The default codecs, with the exception of the Microsoft PCM converter, are removed. You cannot remove the Microsoft PCM converter.


Removing a Specific Codec or MCI Device
To remove a specific codec or MCI device, follow these steps:


In Control Panel, double-click Multimedia.

Click the Advanced or the Devices tab.

To remove an audio codec, double-click Audio Compression Codecs, double-click the codec you want to remove, and then click Remove.

To remove a video codec, double-click Video Compression Codecs, double-click the codec you want to remove, and then click Remove.

To remove an MCI device, double-click Media Control Devices, double- click the device you want to remove, and then click Remove.
 

0
 

Expert Comment

by:agkozak
ID: 1644630
Dear jgsax,

The idea of checking with Creative Labs is an excellent one.  They do have a new driver for the AWE 32 system, designed to work with Windows 98.  What suggests to me that this might solve your problem is item two in the text quoted on their drivers updated page:

   Product:  Windows 95/98 - Sound Blaster 16/32/AWE32/AWE64
 
   Filename:  sbw95up.exe
 
   File Date:  980701
 
   File Size:  316,013 bytes
 
   Description:  Full duplex Sound Blaster 16/32/AWE Driver
   Updates for Windows 95/98
   SDR-95UPD-1-US (REVISION 14)

   1. Windows 98 support
   2. Fixed the default midi device not selected in multimedia
   applet problem.

Go to their update page at

http://www.soundblaster.com/wwwnew/tech/ftp/ftpnew.html

to get this new set of drivers.


Good luck!

A. G. Kozak
0
 
LVL 7

Expert Comment

by:dankh
ID: 1644631
JG,

  Yes, please see if there is an update.  If so, uninstall and reinstall your sound drivers.  It appears as though you are missing some components in your current installation.
0
 
LVL 1

Expert Comment

by:fmismetti
ID: 1644632
Look, you need two cables, one for wav, midi sound and another for cd audio. If you have only the first one you will never play cd audio. Do you have these two cables connected?
0
 
LVL 2

Expert Comment

by:wardog
ID: 1644633
You can play Audio CD from DOS,  so your Hardware is fine. The only suggestion I have is to make sure that there is a line in your system.ini under [mci] that reads
cdaudio=mcicda.drv
also try re-extracting MCICDA.DRV using System File Checker
(START-->Run-->Sfc and hit enter)  and using the extract a single file option
0
 
LVL 12

Expert Comment

by:public
ID: 1644634
You probably have a problem with the thin analog audio cable connection to the sound card. Did you ever try the earphone jack on the cd front panel?
0
 
LVL 1

Expert Comment

by:british041297
ID: 1644635
hmm seems this lil' problem has been going a while,

1.) if you hear music through the front headphone jack then great if not .. your CD can't handle the CDA (which is odd so I would assume a faulty drive as it plays the extended CD's fine)

2.) try getting hold of a DOS based CDA player and see if that works, if it does great, if not then you have a windows driver / IRQ problem.

3.) check that the audio cable is not bent or twisted or broken in anyway.

4.) check that CD-Audio is enabled on your soundcard.

hope this helps

BRiTiSH
0
 

Author Comment

by:jgsax
ID: 1644636
Perplexing problem.  I get sound through my ear phones.  Sound plays on games, both Dos and windows.  Some games are played straight from the CD and the voice and music come through fine.  I'm not going to mention the steps individually this time but I've tried every suggestion listed above and still no solution.  

If I can't play audio tapes it's not the end of the world but I sure can't figure out what the solution to this problem is.
0
 
LVL 1

Expert Comment

by:jrgaylor
ID: 1644637
do you have a" line in" jack on your sound card, if you do you could run a cable from your head phone jack around to the back to the line in jack it would lok kinda hooky but it may give you cd audio.
0
 
LVL 1

Expert Comment

by:mlaiosa
ID: 1644638
I assume that the sound worked before you installed win98.  If so, there is no scence checking hardware. It *is* a software problem.

Becaouse you can hear sound from the head-phone jack, the CD is actually playing, and therefore has to do with the volume, etc settings for you sound card.

Have you tried playing CDs with Media Player, CD Player, FlexiCD (or any other software you might have)
0
 
LVL 5

Expert Comment

by:jboddy
ID: 1644639
0
 
LVL 1

Expert Comment

by:kencam
ID: 1644640
I would bet that your software control program for the Soundcard has either the volume turned down, a radio button not checked for playing CD's or some such oversight.  Be sure the volume is turned up, make sure it is on line, using a button or other method in the control software program.
0
 

Author Comment

by:jgsax
ID: 1644641
Sorry, but every button, sound volume control etc. has been checked and rechecked so that is not the answer.  
0
 
LVL 1

Expert Comment

by:storm996
ID: 1644642
jgsax, can you confirm that you have the small audio cable correctly connected at both the drive and the soundcard??  Without this cable correctly installed you ain't gonna get no CD-Audio.
0
 

Author Comment

by:jgsax
ID: 1644643
DUH!!!  I feel like an idiot.  I finally opened up my computer and found......the small audio cable mentioned above was hanging loose and not connected to anything.  I connected it to my sound card and I now have CD Audio ( it is playing as I type this).  

In my own defense, I did not install the CD Rom drive it was installed at the store where I bought and I had no reason to believe that it was not connected properly.

I wish to thank and apologize to all who offered help.  

STORM996::
Thank you for waking me up and getting me to check the cables.  As far as I'm concerned you deserve the points but that option is not available to me at present.

Anyway the question is answered and again thanks to all for the help.
0
 
LVL 1

Expert Comment

by:mlaiosa
ID: 1644644
I would like to tell you the storm996 was not the first persion to tell you that this cable was probably the problem.
0
 

Author Comment

by:jgsax
ID: 1644645
You're absolutely correct miaiosa and I was remiss in not acknowledgeing that.  

I would like to thank everyone for offering their assistance and especially those who were correct in mentioning that it was a cable problem.  

Something about the way storm996 addressed it to me made me double check to see if the store had properly installed it and I should have looked when it was previously mentioned.


0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
ID: 1644646
As I mentioned, it is a sample problem. A 600 points sample problem! :))
0
 
LVL 12

Expert Comment

by:Otta
ID: 1644647
> Some games are played straight from the CD
> and the voice and music come through fine.

These games use the sound-card to "generate" the sound,
i.e., from WAV or MIDI files, which are read as "data"
from either your hard-drive or your CD-ROM.
The "generated" signals are fed into your speakers.

However, audio-tracks on the CD must be sent through
the four-wire cable connecting the CD-ROM with the sound-card,
to become "merged" with the above "generated" sounds,
and also get fed into your speakers.

A "broken" or "non-connected" wire will show up
only(!) when you try to play an audio-CD.



0
 
LVL 2

Expert Comment

by:DannoNZ
ID: 1644648
What games do you have (trust me, this is relevant)  If you have either Total Annihilation or Warcraft II or any other game that plays CD data music files (you can check this by putting them in your stereo and seeing if they play music) and telling me if the music works in these WITHOUT THE MIDI CHECKBOX CHECKED (i.e. empty)
0
 
LVL 1

Accepted Solution

by:
storm996 earned 600 total points
ID: 1644649
jgsax,
Can you confirm that you have the small audio cable correctly connected at both the drive and the soundcard??  Without this cable correctly installed you ain't gonna get no CD-Audio.

0
 

Author Comment

by:jgsax
ID: 1644650
I am closing this question out but in all fairness and because I was too stupid to check earlier, I really feel that larbel, skaton187 and fmismetti sould all share in the points.  they all suggested that I check the cables.
0
 
LVL 1

Expert Comment

by:storm996
ID: 1644651
jgsax,
Thanks for the points.  Main thing in all this is the fact that you got your problem sorted.  Thats what all this is about.
take care.
0

Featured Post

Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now