Solaris X86 Using PPPD

I am trying to configure a Solaris X86 using Linux pppd software.  I am having trouble calling the modem in my ppp-on script.  For some reason I have tried many of the ports and yet it still is not working.  Below is the line that fails. (By the way all permsions on files are 777)
/usr/local/bin/pppd debug lock modem crtscts /dev/cua0 57600 \

In etc/remote I have a hardwire of /dev/cua/b.  When root does a tip hardwire it says "all ports busy".  I have registered the modem in admintool.  Any suggestions, on how I can trouble shoot or resolve this problem.  

Please, be specific as possible.  Thank you in advance
Who is Participating?
buzhConnect With a Mentor Commented:
the ppp-on script should be the following (according to the man-page) some adjustments may be needed.

pppd /dev/cua1 38400 debug modem crtscts

I'm not sure why you'd want lock, tho. But if you want to use it, it should work.

And, How are you connecting? You might want to add 'connect "chat -f dial.script' to the options and make a file called dial.script containing


This would enable you to just run the ppp-on, and pppd would make chat dial.. ofcourse, you'd need chat. :)
Also, if you use pap or chap you'll need a few more options. most sensible isp's do this nowadays, but you haven't given any details.. :)
dkurryAuthor Commented:
Edited text of question
Umm.. isn't the pppd syntax
pppd /modem/port speed options
? perhaps that would help? :)
dkurryAuthor Commented:
Do you mean, I should have a syntax as follows in my ppp-on script?
      pppd /modem/port speed options

Instead of /usr/local/bin/pppd debug lock modem crtscts /dev/cua0 57600 \  

If so, can you please confirm this and rewrite the new line for the PPP-ON syntax.
           Thank You,

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.