56K modem on Linux

Recently, I changed my old internal 14.4K modem to Hayes Optima 56KFlex (Rockwell) external modem on my PC which runs RedHat Linux 4.0. I have two PPP links, one of which was set to be automatically linked at boot time. I could switch to another link (different phone number) by deactivating the default one and then activating another with the old modem. With this Hayes 56K modem, however, I cannot turn off the default link any more, even by manually running the ifdown-ppp command. If I don't set one link activated at boot time, I can switch back and forth between the two links with no problem after logging in. Could anybody please help me out why the default link activated at boot time cannot be deactivated on this 56K modem?

Another small question is whether there is anyway to know the connection speed of modem on Linux. I didn't feel dramatic speed improvement with this 56K modem. I just want to make sure the connection speed is around 40K.

Thank you.
zchenAsked:
Who is Participating?
 
sparlinConnect With a Mentor Commented:
Not sure aboutthe first part of the question, but for the second question:

When you connect to the net using ppp, use chat with the -v option (chat -v) and when you connect watch your syslogs, (tail -f /var/log/messages) You will get to see the speed you are connected at. As far as real time, try using 'pppstats'.

Sonny
0
 
jwilcoxCommented:
I don't know the answer to the first part of the question, however as far as the second question, with a modem above 38400, you'll need to run setserial /dev/modem(or whatever)
spd_hi.
        Jason

0
 
zchenAuthor Commented:
Hi, Jason,

Thank you for the suggestion. I also want to know whether the speed can be monitored in realtime, like some software can report how much the baud rate is.

0
 
zchenAuthor Commented:
Hi, Jason,

Can I set the serial port at spd_hi at boot time? It seems I need a /etc/rc.d/rc.serial file to do so, but I don't have one. Anybody can set a copy of such a file to zchen@fast.net? Thank you very much.
0
 
jwilcoxCommented:
I actually have my spd_hi set in my /etc/rc.d/rc.local.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.