We help IT Professionals succeed at work.

How to put Netscape back under Xwindows menu networking bar?

joe_massimino
on
Medium Priority
278 Views
Last Modified: 2013-12-15
I managed to get dialup PPP to work, I have netscape working, but:
1) When I tried NEtscape for the first time I got nothing. I then removed it and reinstalled it from the Red Hat disk.
I am using the Win95ish desktop, but when I use any other desktop I get the same thing.  The current condition is that I can see Netscape in my program menu under networking, but when I click it, it does not open. I have to go into file manager and go to /usr/lib/netscape and find it there to use it.  I suspect that the path to the file is missing, but I have yet to fingure out where the date for these menus is stored, or how the path in Xwindows is changed.  I don't know for sure what is going to fix this, but the path is what my current thoughts are.

     Other Info:

                Red Hat 5.1 Manhattan
                Kernel 2.0.34
                Intel Pent Pro
Comment
Watch Question

Commented:
What type of Window-manager do you use?

Author

Commented:
Edited text of question
And what's your distribution and distribution version?

Author

Commented:
Edited text of question
They use all sorts of m4 scripts in /etc/X11/AnotherLevel/ and a master config file called /etc/X11/fvwm/system.fvwmrc

Anyway the execute "netscape" so I think you shouldn't have any problem if you can do a succesfull which netscape at the bash prompt (after starting X)

Good Luck

Author

Commented:
Maybe you can tell me what file to edit, and how t oedit it? I looked at th files you mentioned, but I can not edit them in any way that I know. I can not execute netscape without first going to the directory where it exists.  It will not execute from the Xwindows menu bar, but the button is there.  I'm guessing that i need to edit the link for the button to show it where the file is located.  Post something that makes a little more sense, read it to yourself before you post it to me. I am a novice when it comes to Linux.
You have a problem then... First of all I must suppose you get nothing when you type

which netscape

at the bash prompt... because you need to CHANGE to /usr/bin to execute netscape... This means two [BAD] things: first you DON'T have "/usr/bin" in your PATH and you DO have "." in it... This two things must NEVER happen in a unix system...

Check your path (echo $PATH) to make sure I'm NOT right. If I am, check how you are setting PATH in /etc/profile, $HOME/.bash_profile and (maybe) /etc/bashrc

your PATH should look like:

/bin:/usr/bin:/usr/X11R6/bin

no dots... Tell what you find...

Good Luck,

PS: /usr/bin/netscape is an awful script (ala redhat) which finally executes /usr/lib/netscape/netscape-communicator (or navigator, the first it finds...)
while waiting for your answer... (I'm leaving in half an hour)...
I say it's bad to have "." in your PATH because if you as root change dir to /tmp and then execute "ls", you are supposed to get a file listing, but what happens if someone left an script (called "ls") in /tmp? In this case you execute this script, which could contain a line like "rm -fr /" ...

And you must have "/usr/bin" in your PATH because there you have most usefull binaries...

Finally I suppose you know that the environment variable called PATH is where you store a colon separated list of directories where you look for executables and that the easy way to look at your environment is the command "env"...
And one more suggestion: to edit (if you come from M$ environment), to edit a file:

mc -e filename

(and you are right: I don't read what I write, nor what you ask, sorry...:(  )

Author

Commented:
I will print all that you have typed and read it as I look over what I have. I do not know what happend during the install on this PC, but the other one I did went fine. I am booted in Win95 right now and won't be able to get take a good look until the weekend. As for the parts of your post that I do understand, I must have /usr/bin in my path because many commands that should come from /usr/bin are working at the root prompt.  

Now I've got another question to post about Apachi web server

Author

Commented:
Nope, none of this helped me any. I am going to figure it out one way or the other. My path is OK, and netscape is back in the menu under X, but still goes nowhere, it doesn't give an error either.
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
You would have to give me the details on doing this. I am new to Linux, and although I understand what you saying, I do not know the correct syntax to do it.
joe_massimo: where's your netscape executable? if it is where you stated first (/usr/lib/netscape) [I can't imagine why] give the following command as root:

ln -s /usr/lib/netscape /usr/bin

this would make a symblolic link of the executable to a publicly known executables dir...

Good luck...
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.