Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Powertoys auto network login won't work w.98

Posted on 1998-09-08
16
Medium Priority
?
416 Views
Last Modified: 2013-12-28
Coming from w95 I liked the powertoys ability to provide
auto login to the (private) network. Unfortunately this
does not work for me under 98 + powertoys 98.
Anybody can provide a clue here?

Entered a username and empty password in TweakUI...
0
Comment
Question by:triton090898
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +3
16 Comments
 
LVL 10

Expert Comment

by:MasseyM
ID: 1644707
Do you have the Microsoft Client For Networks installed in the Network Icons via Control Panel?
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1644708
You need to put password
0
 
LVL 10

Expert Comment

by:MasseyM
ID: 1644709
Password is not necessary with the TweakUI...

0
Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

 
LVL 1

Expert Comment

by:Mrfixit
ID: 1644710
I'm having the same problem. Sometimes it will work when you cold boot. But most of the time it does not work. MS does not provide any support for these utilities. You can find this information in the registry.
0
 
LVL 6

Accepted Solution

by:
ckayter earned 200 total points
ID: 1644711
First, use the Win98 TweakUI (ver. 1.25). You can find this on the CD. It is not available for d/l from the 'net.

CD Drive:\tools\reskit\powertoy\tweakui.inf

Secondly, as JBURGHARDT said, you need to enter the password. Not every time, just once in the field designated for it on the TweakUI Network Tab.

Now, if you have an intranet or LAN, you need to set security to automatically log on to the network.

Open IE Browser, View Menu, Internet Options.... Alternately, you can do this from Control Panel, Internet icon.

Go to the Security tab, and select the Local Intranet Zone from the drop list at the top. Select CUSTOM from the radio button list, then click Settings... button. Scroll toward the bottom of the list until you see "User Authentication." Verify that it is set to "Automatic logon only in Intranet Zone." If you are not the network administrator, the IE security may be set in such a way that you cannot edit your security settings...


Lastly, there are some entries in the registry (don't forget to back up the registry before you play in here).

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\SO\AUTH\LOGON\COND (Set by IE controls above)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\SO\AUTH\LOGON\SILENT  (Set by IE controls above)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net, value in right pane: autologon    data=1 (yes) or 0 (no)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Winlogon, value in right pane: autoadminlogon     data=1 (yes) or 0 (no).


Hope this helps. I agree, TweakUI is the BEST. And you'll love the new version (which probably doubles the number of "tweakables")!!!!


Colleen
0
 
LVL 10

Expert Comment

by:MasseyM
ID: 1644712
That is not correct... There is no need for a password.  It all has to do with having Microsoft Client installed and making that your client login.
0
 
LVL 6

Expert Comment

by:ckayter
ID: 1644713
You're right, Massey. It has a field to enter your password, but you can leave it blank (in fact, mine is blank!). Been so long since I'd seen it....

Colleen

0
 
LVL 1

Expert Comment

by:Mrfixit
ID: 1644714
Testing colleen answer I was missing the key under real mode net
0
 

Author Comment

by:triton090898
ID: 1644715
Sorry, hadn't had any time to check it out and so I'm still
unable to do your friendly provided help the least bit of justice.
Hope this will happen soon.

Anyway, I think it's definately the right direction and so
I'm giving those points away lightly hearted :-)

Thany you.

0
 
LVL 6

Expert Comment

by:ckayter
ID: 1644716
Thank you, triton...

You can post a 0 point question for me if that doesn't work...

Colleen

0
 
LVL 1

Expert Comment

by:Mrfixit
ID: 1644717
Still an intermitting problem for me.
Sometimes it works from a cold boot
0
 
LVL 6

Expert Comment

by:ckayter
ID: 1644718
Mrfixit, have you cracked open the registry and tweaked it directly as indicated in my instructions to triton???

CK
0
 
LVL 1

Expert Comment

by:Mrfixit
ID: 1644719
To colleen,
yes except I'm missing some of the registry entries
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\SO\AUTH\LOGON\COND (Set by IE controls above)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\SO\AUTH\LOGON\SILENT  (Set by IE controls above)

You stated that these entries are made by IE not true they dont exist on my machine I will put them in place after backing up the registry. You know win98 makes a backup every time you start but how can you go back? silly me got carried away I'll make the entries and let you know.
these are the values for IE. That should not affect logging into win98. Should work doesn't another bug maybe
0
 
LVL 6

Expert Comment

by:ckayter
ID: 1644720
MrFixIt, you can probably create these keys in IE.

View Menu, Security Tab, Custom, Settings... button. Scroll Down to USER AUTHENTICATION. Select "Automatic logon only in Intranet Zone" or "Automatic logon using current user name and password."

Worth a shot???
0
 

Author Comment

by:triton090898
ID: 1644721
Well,

here I am again. The problem has changed slightly. Autodial is working now, except that I allwas have to reenter the /%$%$-Password...

I've checked 'Save password' in the Dial-up-network dialog box, of course...

Anyone?

triton
0
 

Expert Comment

by:bohmmrwc
ID: 8321552
Well, you probably created a shortcut/link from your
desktop or start menu to the real entry in the dial-up
network, right?

The problem is that it is not a real link, but rather some
kind of copy.

The solution is simply to delete the exportet dun-entry
from your desktop or start menu, then going to the real
dial up network folder and start dialing up from there,
enable "save password" and entering the password. After
one successful log in from there, you can re-create the
shortcut on your desktop or start menu and from then on
it ought to work.

Regards,
Niels
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configuring Remote Assistance for use with SCCM
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question