Solved

Composer locked file

Posted on 1998-09-12
9
278 Views
Last Modified: 2010-04-25
When I try to save my edited web page in Netscape's Composer, I get a message that the file is either locked or the disk is full.  Neither is true (unless the file is locked by default but it doesn't show as being locked).  What am I doing wrong?
0
Comment
Question by:Quackerback
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 5

Expert Comment

by:paulvaneykelen
ID: 1540026
This is very limited information. In general we need to know computer model, system etc.

My guess is you are trying to save the file to the desktop. Save the file on your hard drive. (create a folder on your hard drive). There is a bug? in system 8 and 8.1, which in certain cases will not let you save a file to the desktop, regardless of how much hard drive space is left.
0
 

Author Comment

by:Quackerback
ID: 1540027
I am trying to save it to a folder in my Netscape folder, not the desktop.  I am using a PowerBook 5300, System 8.0, but had the same problem when I was using System 7.6.
0
 

Author Comment

by:Quackerback
ID: 1540028
See my response above.  (I am not saving to the desktop.)
0
On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

 

Expert Comment

by:Eliezer
ID: 1540029
This has happened to me as well, and has been reported elsewhere.  I have not seen a good reason.  Choose "Save As" and give it a different name; quit, delete the old file, rename the new file to the old one's name, then reopen.  At least the error is intermittent.
0
 

Author Comment

by:Quackerback
ID: 1540030
There surely must be a fix for this.  I'd rather buy another product that use the cumbersome proceedure of renaming and deleting files.  I can't believe Netscape hasn't fixed this.  BTW, this is NOT intermittent.  It happens to me 100% of the time.
0
 

Expert Comment

by:cheryll
ID: 1540031
Go to the Netscape Composer preferences and select cache. Give it 2,000k more than is listed. Now give it a try. Netscape does have a disk cache that holds items in the netscape memory and in the folder.  
0
 

Author Comment

by:Quackerback
ID: 1540032
I increased the memory preference by 4,000k (to 10,000) and it still gives me the same message when I try to save a file.  I have also upgraded by system to a PB 3400.  Now I just get that same message faster!  I will try upgrading to version 4.06 to see if that helps.
0
 
LVL 2

Accepted Solution

by:
AdamS earned 150 total points
ID: 1540033
Hi Quarterback,

I'm giving you an answer and I dont think you're going to like it.

I duplicated your problem easily. I took this page where I'm typing this response and selected "Edit Page". I chose "Save As..." and used the default name (whatever was in the "Save As.." text field.  When I tried to edit it and then save it, I couldnt and got the same message you did.

The way I fixed it was to "Save As" and gave it a different name. From then on, I used the file with the new name and could just "Save". Dont worry about the file name effecting the published html name.  Changing  the Mac file name wont affect that.

Also, I was able to prevent this from happening in the first place. Right after selecting "Edit Page" I chose "save as..." (for the first time), and instead of using the "default" file name I gave it something else. Then, subsequent "saves" did not cause any problems.

I dont know why this happens, but there is your "fix"

Adam

0
 

Author Comment

by:Quackerback
ID: 1540034
Why won't I like it?  I don't understand why this works but it does.  I am a happy man.  Thank you.

PS  I upgraded to 4.5 and it does the same thing.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steve Jobs once said that Blu-ray is "a bag of hurt". As Macs users well known, things haven’t settled down (at least not from Apple’s perspective). Several years after that comment, Mac OS X still doesn’t support Blu-ray playback, nor has any Mac s…
Is your phone running out of space to hold pictures?  This article will show you quick tips on how to solve this problem.
Users will learn how resize a batch of photos from a single command in Photoshop via Photoshop's Image Processor. Open up an Image you'd like to resize in Adobe Photoshop: Adjust the image size according to your preferences. Image > Adjustments > …
Users will learn how to set proper sequence settings, scale images, paste attributes, add transitions, fades, and music. Open up Final Cut Pro 7 and Create a new Project: Set the Sequence Settings. a) Click File > Easy Setup > Format > Apple ProRe…

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question