CD-rom problem

I have hitachi 4x Cdrom and I use Redhat 5.1 when I boot kernel sees ide tape drive not cdrom when I boot from bootdisk from win98 my cd rom detected and also when I use autoboot from cd-rom what I need to do do get my cd-rom working under linux
LVL 5
JBURGHARDTAsked:
Who is Participating?
 
t2ppConnect With a Mentor Commented:
JB, the only way you'll get this working is to code the following in your /etc/lilo.conf...
append = "hdx=noprobe hdx=cdrom"
where "x" is your CD-ROM's device.
Good Luck :)
0
 
pestilenceCommented:
Simply do the following after you have booted in Linux:
#] cd /
#] mkdir cdrom
(take a look at the appropriate hd that coresponds to your cd , you can see that while the Kernel boots e.g
hdd IDE ATAPI CDROM HITACHI)
#] mount /dev/hdd /cdrom
and you are ready...

0
 
JBURGHARDTAuthor Commented:
The problem is that cd-rom is seen as ide tape drive not cd-rom can add stuff to lilo like hdx=cdrom(I try this but kernel said that tis is bad option)
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
JBURGHARDTAuthor Commented:
It did not work kernel see cd-rom as tape drive
0
 
JYoungmanCommented:
You don't ACTUALLY say "hdx=cdrom", you use the correct name for your CD-ROM drive, for example hdb, hdc, or hdd.

0
 
JBURGHARDTAuthor Commented:
I removed jumper from cd-rom (was set as slave) and got new vlb ide card
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.