?
Solved

bad entry in fs!?

Posted on 1998-09-13
11
Medium Priority
?
323 Views
Last Modified: 2010-04-22
Sep 12 00:00:03 central kernel: EXT2-fs error (device 08:02): ext2_readdir:
bad entry in directory #1727795: rec_len is smaller than minimal - offset=0, inode=1727795, rec_len=4, name_len=1

What the hell is this?  I run a perfect Linux server but I always get this every once in a while.  Anyone????

I run a Slackware 3.4 with kernel 2.0.35 and a buslogic BT958/Western Digital 4.3 SCSI3 HD.  BT958 bios 5.07b.

Please!
0
Comment
Question by:scottg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 2

Expert Comment

by:JYoungman
ID: 1638020
You apparently have a corrupted directory entry.  First, fsck the filesystem.  Go to single-user mode ("telinit 1") and then fsck that filesystem ("fsck -t ext2 -f /dev/sda2").  Then find inode 1727795 ("find /the-sda2-mount-point -inum 1727795").  The output of that command will be the name of the directory which contains the corrupted entry.

Recreate the whole contents of that directory from a backup.  The problem directory entry won't be appearing in directory listings or backups itself.

0
 

Author Comment

by:scottg
ID: 1638021
Fixing it is the easy part.  I need to know how to stop it from happening in the first place.  Its appears to be random.  I really don't need a corrupt /usr directory.  Usually its been something in /usr/src which I don't care about.
0
 
LVL 2

Expert Comment

by:JYoungman
ID: 1638022
Since you have a stable kernel and a decent SCSI system, I'd be very much inclined to suspect your memory.  I have had FS corruption caused by bad DRAM; even involving files that never really got read.  After I made useful complaints to the supplier, they changed the SIMMS I was using and the problems went away.

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:scottg
ID: 1638023
I'll try replacing the memory, I'll know soon I guess.
0
 
LVL 2

Expert Comment

by:JYoungman
ID: 1638024
Let me know how it turns out.

0
 
LVL 2

Expert Comment

by:JYoungman
ID: 1638025
Hello?
0
 

Author Comment

by:scottg
ID: 1638026
I haven't responded because I'm still waiting to see if it screws up or not.  I made some changes such as reseating the memory in  different banks, slowing the SCSI transfer rate from 40 to 20MB, downgrading my SCSI bios(apparently recommended if under Linux), and tested for HD bad sectors and scanned the memory to see if there was trouble there.  No bad sectors, and the memory seems ok - although there was a small timing error with the memory, but this might have been the cheap program because all other scans(3 different ones) indicate ok.

Even know its been error free for 5 days, that means nothing.  I've had it go for 2 1/2 months before the error surfaced again. Give me about 5 more days...
0
 
LVL 2

Expert Comment

by:JYoungman
ID: 1638027
I reckon the reverse.  If only one of the three programs detected an error, I'd think that the other two are less discerning :-)
0
 

Author Comment

by:scottg
ID: 1638028
It appears to be ok.  Although that doesn't mean much, I've had it go longer without a problem before.  It should be ok.

How the hell to I answer your original question? I got no option to do that on this page.
0
 
LVL 2

Accepted Solution

by:
JYoungman earned 600 total points
ID: 1638029
Heh.  Glad it seems better.  I guess you could accept this
dummy answer: "I think that you need to exchange your RAM for some that works, Sir!".

Don't forget to come back if it doesn't work after all...
0
 

Author Comment

by:scottg
ID: 1638030
Thanks.
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month9 days, 23 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question