Solved

easy one

Posted on 1998-09-16
2
191 Views
Last Modified: 2010-03-18
Let me start by saying that I have no idea what I am doing. I am trying to set a redhat 5.1 machine on a small IP network(win95 and win nt) at my house.  I had it set up at work and it worked fine. i got home started xfree86 and used the network control panel to remove the dns info, change the ip address and domain name.  Now I can't ping the thing. I can ping the loopback just fine. I tested the cable on another machine and it is fine. I ran ifconfig and noticed that my broadcast address was wrong(could that prevent me from pinging?)... I couldn't find any info on how to change it so i typed ifconfig "my hostname" broadcast address down. I received a hostname lookup failure error. ever since, when I run ifconfig it only shows info on my loopback address. What have I done and how do I fix it? Thanks, Jason
0
Comment
Question by:jasonsp
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 1

Accepted Solution

by:
niges earned 20 total points
ID: 1586833
Umm, if the ifconfig broad cast address is wrong, then you will not be able to ping as the computer will try to ping to a network that is theoretically not there...

what you need to type (as long as I can remember off the top of my head --I am on a win95 puter at uni) is--

ifconfig eth0 <your-ip> netmask 255.255.255.0 up

where <your-ip> is the ip of your computer eg 192.168.1.1 and if you use that number system then make sure the netmask is what I wrote, if you use a different number system, you will have to change the netmask..

then you should type 'ifup eth0'

--Nige
0
 

Author Comment

by:jasonsp
ID: 1586834
I actually read somewhere that this is the way to do it.. After I typed ifup eth0, I got this-
route: netmask doesn't match route address

Here are my IP settings:
IP= 134.62.70.70
netmask= 255.255.0.0
new broadcast= 134.62.255.255

I have since rebooted and my broadcast address went back to the old one and I still can't ping...
Thanks

0

Featured Post

Cloud Training Guides

FREE GUIDES: In-depth and hand-crafted Linux, AWS, OpenStack, DevOps, Azure, and Cloud training guides created by Linux Academy instructors and the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question