• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 164
  • Last Modified:

Dial Up Connection Speed

Under win95, my isp connection rate was a consistent 48000, but with a clean install of win98 it shows 57600 everytime.
I understanding the 53000 limitation, so I assume this is a bogus no. at 57600. I changed my modem speed to 115200 with no change...always 57600 ....is this a windows 98 bug...?
ps..My second isp under win95 connected at 52000 pretty regularly and always more than the first isp I mentioned..I have yet to try it.
0
firemann
Asked:
firemann
1 Solution
 
OttaCommented:
Your motherboard's COM port communicates to the modem at 57600,
and your modem "negotiates" a speed of its own
when you connect to the ISP's modem.
So, if you see '57600', you are seeing the speed of COM port,
not the speed between the modems.
The "negotiated" speed varies, due to the
different "path" through the telephone-company's network
for each different call to each different destination/ISP.
0
 
firemannAuthor Commented:
Otta..thanks that makes sense, but why do I get the connections sometimes at 26400 etc. if what you say is true...or is that a win95 phenomenon...
0
 
tazziedevilCommented:
Win98 uses an AT&F command in the string it uses to initialise the modem.. This can some times cause a problem with some modems as it resets the modem back to factory defaults. By adding  atw2^m in your modem properties/connection/advanced extra settings area it will force the modem to report DCD (Data Carrier Detect) speed ie. Line speed instead of the port speed between the terminal and the modem.
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
OttaCommented:
> with a clean install of win98 it shows 57600 everytime.
versus
> why do I get the connections sometimes at 26400

I'm confused. "everytime" or "sometimes" ??

If you see '33600' or '28800' or '26400',
then you are seeing the speed "between" the two modems,
as a result of the "negotiations" which they perform,
as they "test" the telephone-company "line-quality"
for this particular connection-circuit.
0
 
firemannAuthor Commented:
Hey tassiedevil...tried your fix and the modem will not initiate and i have to reboot to reset it...any other thoughts...I have a sportster 56.6 data fax internal...
0
 
firemannAuthor Commented:
otta...sorry the 26.4 number came from the  old win95 install, not the win98 that I am currently asking about.. it always shows 57,600 no matter what the modem speed is manually set at
0
 
OttaCommented:
For a US Robotics modem, use 'AT&F1' to initialize the modem,
and then report the full text of the 'CONNECT nnnnn/xxx/yy'
string in this forum.
0
 
firemannAuthor Commented:
Here you go otta: this is modem log after I put the "AT&F1" string in the advanced settings area....my connections shows to be at 48,000 which is where it was under win95 most of time...
 
09-23-1998 11:24:00.28 - Sportster 56k Data Fax in use.
09-23-1998 11:24:00.31 - Modem type: Sportster 56k Data Fax
09-23-1998 11:24:00.31 - Modem inf path: MDMUSRK1.INF
09-23-1998 11:24:00.31 - Modem inf section: Modem99
09-23-1998 11:24:00.55 - 115200,N,8,1
09-23-1998 11:24:00.77 - 57600,N,8,1
09-23-1998 11:24:00.77 - Initializing modem.
09-23-1998 11:24:00.77 - Send: ATE0Q0V1<cr>
09-23-1998 11:24:00.77 - Recv: ATE0Q0V1<cr>
09-23-1998 11:24:00.89 - Recv: <cr><lf>OK<cr><lf>
09-23-1998 11:24:00.89 - Interpreted response: Ok
09-23-1998 11:24:00.89 - Send: AT&F1E0Q0V1&C1&D2S0=0<cr>
09-23-1998 11:24:01.02 - Recv: <cr><lf>OK<cr><lf>
09-23-1998 11:24:01.02 - Interpreted response: Ok
09-23-1998 11:24:01.02 - Send: ATS7=60S19=0M1&M4&K1&H1&R2&I0B0X4<cr>
09-23-1998 11:24:01.15 - Recv: <cr><lf>OK<cr><lf>
09-23-1998 11:24:01.15 - Interpreted response: Ok
09-23-1998 11:24:01.15 - Send: AT&F1<cr>
09-23-1998 11:24:01.28 - Recv: <cr><lf>OK<cr><lf>
09-23-1998 11:24:01.28 - Interpreted response: Ok
09-23-1998 11:24:01.28 - Dialing.
09-23-1998 11:24:01.28 - Send: ATDT;<cr>
09-23-1998 11:24:01.28 - Recv: ATDT;<cr>
09-23-1998 11:24:02.85 - Recv: <cr><lf>OK<cr><lf>
09-23-1998 11:24:02.85 - Interpreted response: Ok
09-23-1998 11:24:02.86 - Dialing.
09-23-1998 11:24:02.86 - Send: ATDT###,#######<cr>
09-23-1998 11:24:02.86 - Recv: ATDT214,2197700<cr>
09-23-1998 11:24:23.26 - Recv: <cr>
09-23-1998 11:24:23.26 - Interpreted response: Informative
09-23-1998 11:24:23.26 - Recv: <lf>
09-23-1998 11:24:23.26 - Interpreted response: Informative
09-23-1998 11:24:24.26 - Recv: CONNECT 48000/ARQ/V90/LAPM/V42BIS<cr><lf>
09-23-1998 11:24:24.26 - WARNING: Unrecognized response.  Retrying...
09-23-1998 11:24:24.26 - Connection established at 57600bps.
09-23-1998 11:24:24.26 - Error-control off or unknown.
09-23-1998 11:24:24.26 - Data compression off or unknown.

0
 
OttaCommented:
> Here you go otta: this is modem log after I put
> the "AT&F1" string in the advanced settings area....
> my connections shows to be at 48,000 which is where
> it was under win95 most of time...

Is that what you wanted to see?
I usually get 48000 or 49333 when I connect with my USR Sportster,
which is a result of the "quality" of the telephone-
company's wires between my modem and my ISP.

So, if my comment solved your problem,
then reject the current "proposed-answer",
and invite me to post a "proposed-answer",
and then "grade" my answer.  Thanks.
0
 
OttaCommented:
Also, try using *ONLY* 'AT&F1',
i.e., none of the other options,
and see how that affects the messages:
> Error-control off or unknown.
> Data compression off or unknown.
in the log.
0
 
firemannAuthor Commented:
No otta,,, I am sorry if I was not clear ...my problem is not in my win98 connection rate of 48,000...it is with the dialup icon in the taskbar that shows the 57,600 configuration rate that is not the true connection rate of 48,000...is there a way to correct that so that I can instantly check my connection speed....
0
 
OttaCommented:
A guess (not using Win98 at this moment):
right-click on that dialup-icon, and look at its "properties".
Is there an option to display the modem's connection-speed,
rather than the defined speed of the COM port?

0
 
OttaCommented:
A few oddities in the above modem-log:

09-23-1998 11:24:00.31 - Modem inf path: MDMUSRK1.INF
09-23-1998 11:24:00.31 - Modem inf section: Modem99
09-23-1998 11:24:00.55 - 115200,N,8,1
09-23-1998 11:24:00.77 - 57600,N,8,1

Hmm. 115200 was set, and then, only 0.22 seconds later,
57600 was set.

09-23-1998 11:24:24.26 - Recv: CONNECT 48000/ARQ/V90/LAPM/V42BIS<cr><lf>
09-23-1998 11:24:24.26 - WARNING: Unrecognized response. Retrying...

Take a look inside 'MDMUSRK1.INF',
for a string which matches '48000/ARQ/V90/LAPM/V42BIS',
and you probably won't find it.
Hence, you get the "unrecognized" response.

Visit http://www.usr.com and download the latest INF file
for your modem, and update 'MDMUSRK1.INF'.
0
 
Drag2Commented:
Hey Fireman...Here's the scoup about your modem.  With USR's there is not a modem string that will fix the port speed being reported by DUN.  I had the same problem.  
When you install Win98 it tends to corrupt your modem drivers because win98 final release does have some default 56k drivers. It tries to use those in conjuction with the modem factory drivers.
With USR modems you have to uninstall the modem first.  Then pull the modem out boot up so that it does cleanly remove the modem.  Then put the modem back in and load it back up with the USR drivers.  This should fix your problem.
0
 
OttaCommented:
I like DRAG2's "profile"  :-)

> I am a Student studing in Computer programming.

       As good a "stud" as Clinton is, for his age?  :-)
0
 
firemannAuthor Commented:
Thanks Drag2...I will try that...
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

Tackle projects and never again get stuck behind a technical roadblock.
Join Now