?
Solved

Disconecting on incoming call

Posted on 1998-09-19
25
Medium Priority
?
344 Views
Last Modified: 2013-12-27
How do I get my modem to automaticaly disconect me from the internet when there is an incoming call?  (With windows98 and AOL)
0
Comment
Question by:bradsoblesky
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 11
  • 3
25 Comments
 
LVL 2

Expert Comment

by:bushhead
ID: 1144946
firstly, we have clear up a few things.

1. does your phone line have a feature to inform you of an incoming call, ie. a beeping tone of some sort. if you do not have this facility (usually called call waiting), then it is not possible for your modem to get disconnected automatically.

2. if you do have call waiting (beeping sound etc), then there might be a chance that you can get disconnected. there isn't a modem that i know of which listens to the call waiting tone to get disconnected, however some modems have low tolerance for extraneous line noise, therefore this would get you disconnected.

ie. if you have a modem with low tolerance, and someone calls in, the modem would disconnect quickly because of the extraneous noise which call waiting makes.

however, in my case, i have quite a fault-tolerant modem, and this means that the person who is calling usually has to wait above 10 rings before i get disconnected. some people hang up before that time, or some people just don't wait that long, so this may not solve your problem.

if you want to get incoming calls when you are surfing the net, the best thing you could do is probably to divert you calls to a mobile or something, or another land line, or just to a message bank. if you live in the US, you could divert it to a voice pager, and the message actually comes to you while on line.

bush
0
 

Author Comment

by:bradsoblesky
ID: 1144947
Yes We Have Call Waiting. Isn't there some option I could set or something.
0
 
LVL 2

Expert Comment

by:bushhead
ID: 1144948
no, there isn't an option that you can set on your modem. you must realise that the modem is 'listening' in data mode, and the beeps for call waiting are voice mode. therefore it's not possible to do it.

bush
0
Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

 
LVL 12

Accepted Solution

by:
Otta earned 120 total points
ID: 1144949
If you have a 3COM/USRobotics modem, or similar modem,
take your "modem-initialization" string,
and add the option 'S10=1' to _decrease_ the duration,
in tenths of a second, that the modem waits after
loss-of-carrier before hanging up.
This guard time allows the modem to distinguish between
a "line-hit" (or other disturbances that momentarily
break the connection) from a true disconnect ("hang-up")
by the remote modem.

Decreasing the time makes it more likely that the
"call-waiting" alert will trigger a "hang-up" by your modem.





0
 

Author Comment

by:bradsoblesky
ID: 1144950
Otta I have Rockwell HCF 56K data fax pci modem. If I can change the modem initilization string on this type of modem were do I change it.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144951
> If I can change the modem initialization string
> on this type of modem where do I change it?

The initial text which your "dialer" software sends
to the modem is the "modem-initialization" string.
Usually, that string is 'AT&F' or 'AT&F1'.
Change it to 'AT&FS10=1' or 'AT&F1S10=1'.
The exact method depends on which "dialer" software you use.

0
 

Author Comment

by:bradsoblesky
ID: 1144952
I don't understand. Because I know nothing about modems. I don't know where to edit this string.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144953
To edit the string:
++
 close all programs or open windows.
 double click on the My Computer icon.
 open the Dial Up Networking folder.
 right click on your ISP's icon.
 choose properties.
 on the bottom left hand corner,
 click on the Configure button.
 click on the Connections tab.
 click on the Advanced button at the bottom right  
 in the extra settings field,
 type or paste your init string.
 press OK as many times as necessary
 to return to Dial Up Networking.
 close any open windows.
 shut down the computer,
 make sure the power switch goes off.
 reboot and try connecting once again.

0
 
LVL 2

Expert Comment

by:bushhead
ID: 1144954
otta : wouldn't that make the modem more susceptible to line noise and interference as well? like the modem hanging up for no particular reason? heh i would find that most irritating.

bush
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144955
BUSHHEAD wrote:
> wouldn't that make the modem more susceptible to line noise
> and interference as well? like the modem hanging up
> for no particular reason?

Yes, that is _EXACTLY_ the point of using this setting,
so that a "call-waiting" alert will do what BradSoblesky wants,
namely for the modem to hang-up.

> heh i would find that most irritating.

So would I.  But, my proposed-answer is the only way
for the modem to do what BradSoblesky wants it to do,
unless you have a better solution ???


0
 

Author Comment

by:bradsoblesky
ID: 1144956
OK I found where I'm supposed to change the string and I changed it to AT&FS10 =1 is that what I set it to for my modem or is that for your modem. Just to make sure.  Also do I have to turn off call waiting for this to work or do I leave it alone?
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144957
Use 'AT&F1S10=1' for a US Robotics modem.
Try  'AT&FS10=1' for your modem. What is it?
If you *WANT* the "alert" to cause a hang-up,
you must *NOT* disable it!
Selecting "my telephone-line has call-waiting" will
disable it, so you need to *NOT* select that option.
0
 

Author Comment

by:bradsoblesky
ID: 1144958
My modem is a Rockwell HCF 56K data fax pci modem. In process of trying 'AT&FS10=1'
0
 

Author Comment

by:bradsoblesky
ID: 1144959
It is still not working.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144960
I'm away from my USR reference manual,
but I seem to remember another similar-function
"register", namely 'S23', which can be similarly set.

The "not working" description is very hard to decipher.

What happens to the second-caller?
Do they hear a "busy" signal?
Do they hear the "ring" signal?
0
 

Author Comment

by:bradsoblesky
ID: 1144961
They hear the ring.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144962
> They hear the ring.

Good.  That means that the "call-waiting" alert
is being sent to your telephone-line.

So, what happens?  
Does it ring-and-ring-and-ring, until they hang-up?
Does your modem "drop" the connection?
0
 

Author Comment

by:bradsoblesky
ID: 1144963
It just keeps on ringing and ringing.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144964
I checked my US Robotics Reference Manual.
Use 'AT&FS25-1' to set "the duration, in hundredths
of a second, that DTR must be dropped so that the modem
does not interpret a random glitch as a DTR loss".

Setting it to 1/100 makes it more-likely to "hang-up",
as per your request.

 
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144965
Oops!  Sorry for the "typo".
It should have read: Use 'AT&FS25=1'.
0
 

Author Comment

by:bradsoblesky
ID: 1144966
I'll Change It and get right back to you.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144967
> I'll Change It and get right back to you.

To minimize "clutter" within Experts-Exchange,
why not first(!) try it, and only(!) then post a report?
That way, I would get an E-mail notification only when
you had some results to report.  I thank you,
and all the "interested-parties" who are also getting
notification of updates to this question will also thank you.
0
 

Author Comment

by:bradsoblesky
ID: 1144968
Ok. Sorrry, I tried that and it doesn't work either. It just keeps ringing.
0
 

Author Comment

by:bradsoblesky
ID: 1144969
Otta if you cannot help me any further just say so and I will still give you the points for all your time and effort.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1144970
> I have Rockwell HCF 56K data fax PCI modem.

Since I have a USR modem,
rather than a modem which is identical to yours,
I've done all that I can.

If you have the AT command-set documentation
for your modem, look for "switches" similar
in function to the switches (S10 and S25)
which are supported by the USR modem.
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello All, I have been training on Multicast for a while now and whenever I start the topic , I find out that my friends /  Colleagues mention that they do not know how to test Multicast Joins. As most of the multicast would be video traffic and …
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question