FAT32 cannot find CD-ROM?

I wanna install Diablo onto my PC. I use Win98 and I converted it to FAT32. But after I installed Diablo, I cannot play with it. It cannot recognize the CD-ROM. It says it can not find a specific file on the CD-ROM. (I can play it under Win95.) Other games never have such problems. Is it because the FAT32 files system? How can I make it under FAT32?  
Who is Participating?
smeebudConnect With a Mentor Commented:
Tips for Installing Real-Mode CD-ROM Drivers

Currently running Windows 95:

If you are currently running Windows 95, you may already have a portion of the CD-ROM drivers loaded. If you can shut down to MS-DOS mode and get access to your
CD-ROM drive, try the following:

Reboot and press the F8 key at "Starting Windows 95".
Choose "Command Prompt Only."
At the C:\ prompt type: DosStart.bat.

You should now have access to your CD-ROM drive.

Lost Access to the CD-ROM Drive During Setup

If you lose access to your CD-ROM during Windows 98 Setup, you can try the following:

1.Reboot and press the F8 key at "Starting Windows 95," and then choose the option for Command Prompt Only. If you are running MS-DOS, boot directly to
command prompt.

2.Edit the Autoexec.bat file by typing: Edit Autoexec.bat

3.Delete the text "Rem by Windows 98 Setup" in front of the line that includes the reference to Mscdex.exe.

4.Exit Edit by typing ALT-F-X and save the file when prompted.

5.Reboot. Either Setup should continue on its own, or you should run Setup again, choosing Safe Recovery if prompted.

from  http://support.microsoft.com/support/kb/articles/q179/7/56.asp

Regards, Bud
Run scandisk on the Diablo CD.  Does it come out OK?
umm. you can't alter anything on the CD-Rom, unless it's a cd-rw or something. it's likely that you might have scratched it. has the CD ever worked before? if this is your first time, then it's very most likely the cd-rom

fat32 has nothing to do with the CD-rom at all. that won't make a bit of difference. fat32 has to do with harddisks and how files etc are allocated. running on fat32 or fat16 will not make a difference to this installation.

It may be the busmastering that comes with 98.
With BMing it's an either or situation.
Either it works in Dos, or it works in windows, but not both.
DMA Or BusMastering DMA
Bus Mastering reduces CPU overhead by providing a mechanism for data transfers that do
not require monitoring by the CPU.
However, overall CPU overhead should be reduced using DMA mode.
A disadvantage of implementing DMA data transfer operations has been that the PC/AT and
IDE hard disk controller evolved around PIO data transfer methods. As a result, the system
Int 13h BIOS and native operating system device drivers evolved around PIO transfers
instead of DMA transfers.
Modifications to the BIOS, as well as external device drivers, have been necessary to
achieve the incremental performance that DMA offers. Windows 95 OEM Service Release
2 offers native operating system support for many bus mastering IDE controllers.
New in OSR2 is support for Hard Drive/CDROM Direct Memory Access.
With DMA enabled, no processor time is used to access the hard drive or CD ROM. The
result is an improvement in overall system performance.
However, the default for DMA is disabled (for the default OSR2 Bus Mastering IDE
controller drivers)!
Note that varying hardware configurations will show varying improvements in system
performance when DMA is enabled.
To enable HD DMA, go to:
Control Panel/ System/ Device Manager/ Disk Drives.
Highlight your hard drive, click properties.
Click the "settings" tab.
Check the box next to "DMA." Restart the system when prompted,
and repeat for any additional hard or CD ROM drives.
NOTE that the DMA checkbox only appears
1. For IDE drives.
2. Only if the default OSR2 bus mastering IDE controller drivers are installed and
configured correctly. Some IDE drives do not support Bus Mastering.
To determine if your hardware supports Bus Mastering, do the test described at
OSR2 supports Bus Mastering, but only by checking the DMA box, is Bus Mastering
turned "on."
Note that the DMA check box only appears when using the default Windows95 OSR2 Bus
Master drivers. If you are using non-bus mastering drivers, the DMA box won't show up
because Bus Mastering cannot be enabled. If you are using other Bus Mastering drivers, the
DMA box does not show up because it is enabled by default, and you don't have the option
of disabling Bus Mastering.  

                  Using DMA (Bus Mastering) Win98
To Bus Master your system and determine whether your drive supports DMA:

1.Open System Properties in Control Panel (select Start > Settings > Control Panel)
2.Select the Device Managertab
3.Click the + sign next to the Disk drives entry
4.Select the drive you want to enable for DMA and click Properties
5.On the Settings tab, there should be a DMA check box, if this box is unchecked, place a
checkmark. If there is no check box (or it is grayed out), your motherboard chipset does
not support the bus master interface.
If the check box is not checked after you restart your system, your hard disk probably has
been automatically disabled again because the hard disk may not support a multiple-word
DMA protocol. For more information see Microsoft's Knowledge Base Article
You can use the same procedure to Bus Master your CD-ROM Drive.

NOTE: You do not need to install Bus Master drivers if you have Windows 98.
Bus Master drivers build in the Windows 98 system.  

                         USB Troubles?

Re-install the USB driver by going to ->Settings ->Control Panel ->System ->Device
Manager ->Other Devices.... remove the USB driver. Then reboot your PC and when your
W95 startup it will detect back your PC USB driver and just follow the wizard to install
back your  driver.
Also see:
Sean Erwin's Windows 98 FAQ http://www.users.cts.com/king/s/serwin/ 
Windows95 OSR2 FAQ            http://www.compuclinic.com/osr2faq/
go to
http://www.bmdrivers.com/ and get the right BMing drivers for your chipset.

Regards, Bud
There are general warnings about incompatability of DOS games and programs with the FAT32 file system. It has nothing to do with the CD-Rom. I'm not familiar with Diablo, is it a true Windows game or is it running in a windows shell?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.