Paradox table size limit 128 MB

hi folks,

Config: Delphi 3.0 c/s, windows nt 4.0, bde-engine 5.0 with paradox table

I need to create a table that is larger than 128 MB. But each time Delphi stops at 128mb and says that it cannot append any more rows.

Is it possible to have a table larger than 128mb?
If so how do we configure this ??
LVL 1
tha_incredible_boAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
dejohn99Commented:
Have you tried removing all indeces?  I have found that many of the limitations of the Paradox system are related to the primary key rather than to the tables themselves.
0
 
dejohn99Commented:
The other major issue I have run into with the BDE is the BLOB handling sub-system.  In D3 and below, it's flaky as all H under certain circumstances.

Also, the maximum table size is affected by the Block size of the table at create time.  This is set in the BDE administrator under Configuration -> Drivers -> Native -> PARADOX -> BLOCK SIZE.
0
 
tha_incredible_boAuthor Commented:
there are no indices on that table. but it is a nice aspect if you can't have any indices on bigger tables!
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
MatveyCommented:
I have a Paradox table that is 507 MB. It's on a CD, and I won't have enough space to copy it to the HD. It doesn't open in the database desktop, it says the index is corrupt, but it works fine with the application that uses it. The application is quite old, and I supose so is the table. SO , my guess: try to use an old version of Paradox tables (Paradox 3.5, 4 etc.). I supose this might have a chance...

--Matvey
0
 
dejohn99Commented:
I have just tested a big Paradox table under D3 BDE, and had no problems.

1. Check your block size.  Paradox tables are limited by the number of blocks, and so the block size will limit the table size.

2. Are you using any "special feature" fields - such as BLOB, auto increment or lookup?  If yes, try changing those fields to Integer or string fields.

3. What is your record size?
0
 
tha_incredible_boAuthor Commented:
hi dejohn99,

the settings for the blocksize seem to be the problem. i increased the value to 32k and now it works fine.

regarding to your question: i do not use any special fields. my structure looks like this:
id int, tag smallint, tagord smallint, text alpha(255), link int.

the next problem i encountered is the limit of 2 GB for the paradox table. is that the upper final end for a paradox table or can you go beyond that limit perhaps with some tricks like striping? (perhaps you have an idea???)

please send your comment as an answer to receive the points.

many thanks for your helping
bo
0
 
dejohn99Commented:
The paradox standard (See your BDE manuals) has an upper limit of 2GB per table.  For larger tables I would recommend using a SQL based system if possible.  If it is not possible to do this, you could try splitting your data into tables by ID range, perhaps with a master table to indicate which actual table to get the data from.  I have done this to split data into tables by job number here.

My email address is dejohn99@telusplanet.net.  This sounds like an interesting problem, depending on how much table transparency you need.
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
tha_incredible_boAuthor Commented:
thanx dejohn99, i'll keep you informed via e-mail about my problems and solutions ...

CU ;o)
Bo
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.