Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 291
  • Last Modified:

Dead Diamond Monster 3D

My Monster 3D card has simply stopped working.  Video pass through works, the rest of the system works, no driver conflicts, no missing drivers, no nothing.  But any opengl game defaults to software, my Tweek settings are all blank, and I can't get any bouncing balls etc. with the "Test" section of the Monster 3D settings informaion dialog box in Display Properties.  What gives?

The hardware of note:  ADI MicroScan 5P+, Mystique 220, Monster 3D, Win95 OSR2, P166MMX, 32MB.
0
patrickk062498
Asked:
patrickk062498
  • 4
  • 3
  • 2
  • +3
1 Solution
 
juggernautCommented:
have you tried getting new drivers
0
 
patrickk062498Author Commented:
The drivers I have are the most recent available.  My card is less than a month old, and I updated the drivers within that time as well.  Thanks for the info, though. :)
0
 
larbelCommented:
You mean only OpenGL games stop working?  How about Glide game?  Please list the dirver version under Monster3D properites.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
patrickk062498Author Commented:
I don't have any Glide games at present, but all attempts to get anything from the card don't work, even the display test in display properties, as i mentioned above.
My driver versions are:
glide.dll: 2.11
sstlimit.dll: Initcode $ Revision 5 $
dd3dfx.drv: 4.10.01.0013
(same for dd3dfx16.dll, dd3dfx32.dll and fxmemmap.vxd)

Hope that helps...
0
 
tommesCommented:
my brother's monster stopped working after 2 weeks ! He also tried out everything he could (getting the newest drivers, etc.) -nothing helped.
At the very end he returned the card and got a new one.
Not a single problem so far.
Depending how old your card is, can you exchange it with a new one too ? As far as I remember, Diamond is giving a 5 years warranty on most of their cards.
0
 
patrickk062498Author Commented:
That may very well be the problem, but the place I bought the card from is Future Shop, and their customer service policy is non-existant.  Sigh.  And Diamond's web site for tech support is also rather pathetic....impossible to get a hold of a real live person.

If the card turns out to be defective, I'll award you the points, but for the meantime I'd like to see if there are any other less drastic soluctions to my predicament.

Thanks for the info about your brother, tho...nice to know that I'm not the only one with problems of this type.
0
 
tommesCommented:
patrickk: OK, let's try something else. Simply send an email message to the following address:
techsupt.euro@diamondmm.com

Don't enter any text, just put your cards _exact_ model name into the "Subject" and send it. You will hopefully receive an electronic questionaire which you then have to resend to a given address. This worked at least perfectly for me as I had similar problems with my VIPER.

Another thing: Try exchanging the loopthrough cable, this might be defective to some sort (must be easier to do as exchanging the whole board)......
0
 
blood_angelCommented:
does D3D work?
0
 
kinkajouCommented:
Ah, my Voodoo2 from STB works great.

Have you tried using the stock 3dfx drivers off their web site? Most companies like Diamond will build their drivers off of a driver set provided by the video chip vendor, like 3dfx. Most of the time, the chip vendor's stock drivers will work on the retail cards. I know this is true of STB cards.

If the problem occured when you updated you drivers, you may want to revert to a previous driver version.

What tommes talks about above may indicate that the BIOS's on the cards needs to be updated. Something like OpenGL not working is usually not an indication that the hardware is bad.

My STB Voodoo2 uses Glide2 version 2.53, Glide3 version 3.0. Maybe this is the problem?

Do your OpenGL games need OpenGL activation? I know Quake needs to have a setting changed to OpenGL in order to run OpenGL.
0
 
blood_angelCommented:
yeah well, don't get excited I got a Voodoo 2 too A diamond Monster at that!

0
 
kinkajouCommented:
Do you have anything useful to say, blood_angel?
0
 
patrickk062498Author Commented:
Well, I just got my card back from Future Shop, where I had brought it to be tested.  I looked over the Diamond web site, and it looked to me like the card Engine was dead...turns out that's exactly what it was.  The card somehow got fried.  I have no idea how, guess it's just a defective card.  So, the fine folks at Future Slop actually exchanged the card.  Floored me, I was expecting them to stonewall me as long as possible.
So, tommes...please resubmit your answer, and I'll get you the points.

Thanks to all!
0
 
tommesCommented:
my brother's monster stopped working after 2 weeks ! He also tried out everything he could (getting the newest drivers, etc.) -nothing helped.
At the very end he returned the card and got a new one.
Not a single problem so far.
Depending how old your card is, can you exchange it with a new one too ? As far as I remember, Diamond is giving a 5 years warranty on most of their cards.
0

Featured Post

Meet the Family that is Made for Collaboration

The TeamConnect Family product group as part of the Sennheiser for Business Portfolio comprising high-quality, technically well-conceived meeting solutions for business communication – designed for any meeting room and any meeting situation.

  • 4
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now