modem speed

I have a NewComm 56k modem and when I connect, I am only connected at 19200bps.  However, my dad has a Hayes-Acura 28.8 modem and when he connects, he is connected at the right speed, 28800bps.  What's wrong with my modem?
jynxAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
kencamConnect With a Mentor Commented:
Is your 56K set up to connect at 56K using the v.90 standard, the K56 Flex Standard, or the X2 standard?  Then you need to find out what 56K availability is offered at the number to which you are dialing.  You must have compatible protocols to be able to connect at the higher speeds.  You may also be experiencing a short in the phone system in your home.  If you are dialing in from a separate computer on a separate phone jack, try unplugging all the phones in the house from the wall jacks, so the modem in YOUR computer is the only one connected, then dial in.  If you connect at a higher speed, then there is phone equipment with a short in it connected somewhere.  You can isolate it by disconnecting, then plugging things back in one at a time and connecting again, and seeing when the connection speed drops.  I have a phone that I have to unplug from the wall whenever I want to connect, otherwise, I only connect at 14.4.  Give it a try.  Also, check your dial up networking properties for the connection that you are using.  Make sure the connection speed is set to 115,200 and the checkmark is unchecked where it says only connect at this speed.
0
 
bushheadCommented:
besides what kencam has said.

1. are you using the right drivers. modem init strings etc. this can be the cause of many a problem

2. check that the baud rate for the port is set right. but since your dad's modem connects, this is just a wild guess.

bush
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.