httpd say httpd: bad group name nogroup

error message for #httpd
httpd: bad group name nogroup  
please give some help.
mathematicsAsked:
Who is Participating?
 
vxConnect With a Mentor Commented:
Problem:

Your httpd tries to run itself in a group called nogroup. If it doesn't exist, your httpd produces that error message.

Probable solution:

- Create the group nogroup
OR
- Find your httpd's config file
- Read it thoroughly (perhaps run grep nogroup <configfile>)
- Change nogroup to a group that exists or a group that may be used
- If you can't find it in your config file, it must be compiled into the httpd
- Change the config-/makefile and recompile

My opinion:

I think creating the group nogroup is the simplest and securest option. httpd's shouldn't be given much permissions and nogroup has very few. If you want to know more about security and related problems, refer to the documentation.
0
 
vxCommented:
Oh.. adding a group would be done by typing:
groupadd <group>

You can remove it again by typing:

groupdel <group>
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.