• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 290
  • Last Modified:

NT/IIS 4.O 127.0.01 problems

Everytime I click on a link that points to the localhost IP (127.0.0.1), I get an error saying that "A connection with the server could not be established". I have deleted the Administrator Web Site in the past and have tried to recreate it - thinking that was the issue. What is wrong?
0
alavan
Asked:
alavan
1 Solution
 
waynebCommented:
Make sure you can goto a dos prompt and ping the localhost by typing
ping localhost
the system should come back with 127.0.0.1 if not the you may need to add it to your hosts file located in the following location.
c:\winnt\system32\drivers\etc\hosts
and besure that it is defined in this file.
localhost 127.0.0.1

Let me know if you need more help or advice.
0
 
MFKCommented:
If this is from the browser then check if you have configured a proxy. Exclude the local ip addresses from going through the proxy.
0
 
gasimCommented:
How are you trying to restore the web administration application?
The safest way is do that from the Inetsetup.exe program (The IIS Service Installation).
You can access the web based administration page by going to:
http://localhost/iisadmin/iis.asp
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
alavanAuthor Commented:
I can't browse to http://localhost/iisadmin/iis.asp due to the error I stated. Actually, I've fixed the problem by setting the Administrator Web Site to publish c:\inetpub\wwwroot and set the IP to 127.0.0.1. I don't understand why I have to do this though.
0
 
alavanAuthor Commented:
This is a duplicate.
0
 
alavanAuthor Commented:
MFK, there is no proxy.
WayneB, I can ping localhost.
0
 
waynebCommented:
This maybe a bug in Microsoft's web server, if you can ping localhost is a valid address that should work if you browse to it. I tryed to look it up in the Ms knowledge base and found no reference to this problem, but it should work and it does not.
0
 
vvkCommented:
Does your IIS use all avaliable IP addresses? If you configure one to use only specified IP it not binded to localhost address.
0
 
alavanAuthor Commented:
vvk: No, I've allocated about 10 IP's to the Server, of which only 6 are being used. Should I set the Administrator Web Site to <All Unavailable> instead of giving it an IP? What the heck does that mean anyway?
0
 
moellertCommented:
IIS normaly disables the web access of the admnistrative web site. This is done through the security tab in the admin web site properties.
Just enter the IP of the client with which you want to access this web site and everything should work.
0
 
alavanAuthor Commented:
I'm only accepting this answer to get it off the question list. IIS sure does some strange things at times.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now