• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 378
  • Last Modified:

Samba(Red Hat5.1)

Ok here we go.... I have Red Hat 5.1 on one box and Win98 on another,Samba service is running. When I go to network neighbor hood, I can see the Linux drive and the properties say Samba 1.9 or somthing like that, anyway, When I click on that drive it askes for a password, so I type in my root password, it comes back invalid. Then when I telnet into the linux box and type smbpasswd it says: load_client_codepage: filename /etc/codepages/codepage.850 does not exist. then old password: I enter the root passwd the new passwd and retype pass then it says faild to find entry for user root in file /usr/private/smbpasswd. I tried it as a user with the same effect but the final error after retype in the password varies from smbpasswd: machine rejected the session setup. Error was : ERRSRV - ER
Rbadpw (Bad password - name/password pair in a Tree Connect or Session Setup are
 invalid.) or smbpasswd: machine rejected the password change: Error was : The speci
fied password is invalid. HELP!
1 Solution
you should use "smbpasswd -a user" to create a new user (type newline for the old passwd)... Any way try adding the following entry at the end of your /etc/smb.conf:

   comment = Temporary file space
   path = /tmp
   read only = no
   public = yes

to access /tmp without passwd
Fiber-OpticAuthor Commented:
I already figured it out, it was not the Samba server but the Win98 machine having prob's with the password...
I know you said you already figured it out, but maybe this will help other people with the same problem.

Your problem is that the Samba server shipped with RedHat 5.1 does not include encrypted password support. Win95 and original WinNT defaulted to plaintext passwords and work fine with Samba. However, Windows 98 and Windows NT Service Pack 3 or later, by default, will not generate or recognize unencrypted passwords.

The easy solution is to edit the registry on your Windows machine and enable plaintext passwords. Use regedt32 to find the following key:


Add a DWORD value called EnablePlainTextPassword and set it to 1. This will cause Win98 or WinNT SP3 to behave the way Win95 and earlier WinNT have always behaved. Of course, you will still be using plaintext passwords. If you want to use encrypted passwords, the latest versions of Samba include the capability, but you will have to download and compile your own copy to replace the package that comes with RedHat.

Yes it seems to be the Win98 boxs fault. But the Registry entry you gave is wrong.


is where you enter the EnablePlainTextPassword (DWORD) info

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now