Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 673
  • Last Modified:

Timeout from SMTP on HP-UX

I am using the SMTP on HP-UX 10.10 as my email gateway for sending out emails. Currently, there are 20 clients using outlook express on win95 for emailing. There is also a router with 64Kbps link for WAN connection. Recently, I have experience timeout message from SMTP and the email cannot be sent out. I have set the timeout interval on the
Outlook express from 1 min to 2 mins. But the same message still occur. Please advise me on how to troubleshoot this problem?
0
Megahertz
Asked:
Megahertz
  • 4
  • 3
1 Solution
 
blowfishCommented:
The timeout message is being sent from the SMTP (sendmail) daemon running on your HP-UX mailserver.  Changing time settings on Outlook will not help.  

Timeouts will occur if sendmail cannot connect to the SMTP port (25) on a remote system to deliver/forward a message.  When the  sendmail daemon time's out, it will leave the undeliverd message on the message queue (/var/spool/mqueue), and attempt to deliver it every 30 minutes for the next 5 days.  

Time-outs can occur for several reasons, such as; a network link is down, the remote host is down, or the SMTP daemon on the remote system is not running.  

If a message cannot be delivered for 4 hours, sendmail will send a warning message to the sender (Outlook user).  If a message cannot be sent for 5 days, sendmail will send a delivery failure notification to the sender (Outlook user).  This is sendmail's default behaviour, but that can be changed.  

If the warning messages are alarming your users, and you wish to disable them, then do the following on your HP-UX mailserver;

  1.  login as root

  2.  change to the mail configuration directory, and make a backup copy of the sendmail configuration file
  #  cd /etc/mail
  #  cp sendmail.cf sendmail.cf.BAK

  3.  edit the sendmail.cf file and find the following lines;
  O Timeout.queuereturn=5d
  O Timeout.queuewarn=4h

  4.  you can stop the warning messages by commenting the queuewarn line like so;

  #O Timeout.queuewarn=4h

  5.  You should not comment the queuereturn line, but you could change the time delay if you wish.  

  6.  save the file

To activate your changes you will need to stop and then start the sendmail daemon.  Do it like this;

  #  /sbin/rc2.d/S540sendmail stop
  #  /sbin/rc2.d/S540sendmail start

Hope this helps,

--frankf


0
 
MegahertzAuthor Commented:
Hello Blowfish,

Thank you for your rely.
I could not find the Timeout.queuereturn= in my sendmail.cf file.
I could only find the #return time
 The version of UNIX I am running is HP-UX 10.10.
0
 
MegahertzAuthor Commented:
cont'd
it is under the <Localizable Options> as follow:
#return time
0r5m

Is this the same as Timeout.queuereturn= option that you have mentioned.

TIA
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
blowfishCommented:
Most of my experience with Sendmail is with the Solaris version by Sun, and with the Berkely version 8.x.  The only HP-UX systems I have access to identify themselves as "HP-UX B.10.20".  The sendmail running there is (berkely) "Version 8.7.5".  

To determine your sendmail version, type the following at the command prompt (you do not need to be root for this);  

  #  /usr/lib/sendmail -d0.9 < /dev/null

I am not familiar with the lines that you have posted in your previous comment.  If you wish, you can send me a copy of your sendmail.cf via e-mail, and I'll see if I can provide any further suggestions.  You'll find my e-mail address under my profile.  

--frankf
0
 
blowfishCommented:
In your original question you state that you are experiencing timeout messages from SMTP.  Where are you getting these timeout messages, and what do they look like?  


0
 
MegahertzAuthor Commented:
Hello Blowfish,

I will do the testing this weekend and let you know the outcome.
And also not to forget to you the credit.

Cheers,
MegaHertz
0
 
MegahertzAuthor Commented:
Hello Blowfish,

So far it works fine.
:>

Thanks,
megahertz
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now