Solved

Zip drive takes cdrom drive letter!

Posted on 1998-09-30
9
297 Views
Last Modified: 2013-12-29
I have installed the guest95 for my paralel zip drive about four times, the install works great untill I restart my computer. After restart, the zip takes the "I" drive instead of the "J" that it installed with. I have the cdrom assigned first and last drive letter"I". I do not have any of the other problems that the Iomega site says to look for. This same zip worked great on my old win95 486/75. What gives? (like I said, I tried all the Iomega tips).
0
Comment
Question by:lmelton092897
9 Comments
 

Expert Comment

by:shalafi
ID: 1645631
Is the problem that you are losing your cdrom drive letter, or that the zip just isn't staying with the assignment you need? If it's the first, and IOMEGA can't help, the simplest thing to do would be reassign the cdrom to J: and let the greedy zip keep I: (cdroms are a lot easier to reassign than zip drives).
To give the cdrom J: go to Device Manager (System from Control Panel, or right click on My Computer and choose Properties) highlight your cdrom drive, and click on properties. Down at the bottom of the properties page change the Start Drive Letter and the End Drive Letter both to J:. Or, try changing both to I: and see if that forces Win95 to give J: to the zip.

Why so many drive letters? Big hard drive with lots of partitions? Network?
0
 

Expert Comment

by:shalafi
ID: 1645632
crap, just paid more attention to your post and saw that you've already got cdrom set to I: for first and last, so try J: like I was saying. sorry for all the useless info about how to get to the cdrom properties, you obviously know that. and, if it isn't that you are losing the cdrom but just really need/want the zip to be J:, then everything I've offered is worthless. :)
0
 
LVL 1

Expert Comment

by:nrosier
ID: 1645633
i had the same problem; i've used the solution shalafi proposed so that my cdrom always has the same drive-letter, even if my zip isn't connected. You could also try loading the cdrom-dos driver in your config.sys and using mscdex with the /L:<drive-letter> assign the cdrom to your drive I: This way, the zipdrive can only take the next available drive-letter (J:).
hope this helps,

N.
0
 

Author Comment

by:lmelton092897
ID: 1645634
I had planned to add the dos drivers, then win98 crashed completely(nothing to do with the zip). After another 2 hours troubleshooting, I,m back in business! I have forgotten where the switch L:/I to assign the cdrom should be placed. Any help? BTW: I need to keep the cd as I: because that is the source drive for everything that has been installed ie:games, apps, Etc.. thanks for the answers!
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 1

Accepted Solution

by:
jpcs earned 200 total points
ID: 1645635
try writting this in the end of config.sys file

lastdrive=z

reboot computer and see if it worked
0
 

Expert Comment

by:shalafi
ID: 1645636
ugh, would be so much simpler if you didn't need that drive letter for the cdrom :)
the letter assignment goes in both autoexec.bat and config.sys on the device=<driver.sys> and the mscdex lines
remember that any real-mode drivers you add like that suck up a little memory

if you need it:
config.sys -> device=c:\..\cdromdrv.sys /D:NAME001 /L:I
autoexec.bat -> mscdex.exe /D:NAME001 /L:I

the name and the letter don't matter, as long as they are set to the same thing in each file
if you've got himem.sys and emm386 firing up correctly then you can go ahead and use devicehigh= and lh mscdex and maybe get em into upper memory
0
 
LVL 1

Expert Comment

by:nrosier
ID: 1645637
how will lastdrive=z assign the cdrom to drive-letter i??????
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1645638
Be aware that using a Dos real mode CDROM driver may force Windows to operate the drive in slow, Dos-compatibility mode. (Instead of 32-bit, protected mode)
Just change to the desired drive letter for the zip drive under Disk Drives/Settings in Device Manager.
Set the CDROM's assignment under CDROM/Settings.
Regards,
Ralph

0
 
LVL 1

Expert Comment

by:seejay22
ID: 1645639
In Windows 95 you can go to the Systems control Panel and get the
properties of the zip drive up.  Change the First drive letter and the
last drive letter to the Drive letter you want it to have.  Do the same
with the CDROM drive but with the drive letter you want that to have.
IT would probably be best to make the ZIP drive the Z drive.
I can't take credit. Look at:
http://pw2.netcom.com/~deepone/zipjaz/special.html
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now