CDU33a works in DOS, not seen in win95!

I have installed a replacement HDD for the already existing physical D: drive, now there is a drive C:, D:, and logical E:, bumping the cdrom drive up one letter to F:  A command prompt within Windows [DOS] sees this drive letter fine and the cdrom is accessable. Windows does not show the drive in "My Computer" or Device Man. At first it would not work AT ALL until I added the /L:F to the end of the mscdex.exe line in autoexec.bat file. After that it worked but only as described above. Is there something special about this particular model [Sony - cdu33a] and it's seeming inability to use a drive letter above E:? I have also tried the hardware detection wizard with no luck. I have looked high and low for Win95 drivers but none seem to be available - even on the sony webpage.
Any help appreciated.
LubyAsked:
Who is Participating?
 
struyfsjCommented:
Here is a workaround for your problem:
Run regedit and go to the reg key
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer  ---->  delete the NoDrives value.
To be on the save side, write down what it says so you can add it if this does not solve anything.
After deleting close regedit and restart your computer for the registry to be read again.
0
 
rmarottaCommented:
Luby, the drivers for that CDROM come with Win95.
From Control Panel, run Add New Hardware, and click No when you are asked to let Windows detect new devices.
Click on CDROM controllers and select Sony proprietary from the drop-down list, then OK.
When that's complete, check Device Manager and be sure it is using the resources configured on your controller.
Windows should detect the drive on the next boot.
Let me know how it goes,
Regards,
Ralph
0
 
bushheadCommented:
it might be possible that you put the sony drive as permenant e and this could be cause problems.

this can be solved by control panel, system, device manager. go to cd-rom and then get to you cd-rom. then click on properties check the settings for the drive name.

also maybe you turned off the drive to show up in explorer. this can be reset or checked using tweak ui.

bush
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
LubyAuthor Commented:
I have already manually installed the sony proprietary drive with the included win95 drivers. Now the device shows in Device Man. but still doesn't show in "My Computer". I shall try the advice of "bushhead" who says:
>> "this can be solved by control panel, system, device manager. go to cd-rom and then >>get to your cd-rom. then click on properties check the settings for the drive name."

I'll let ya'll know what happened later.
0
 
MATTCEICommented:
By calling Mscdex in Autoexec.bat,you're preventing Windows from starting the protected mode driver for the cdrom drive.Does it show in System - Performance as running in 'compatability mode'?
That line should be moved to Dosstart.bat.
0
 
cumboCommented:
Do you have a LASTDRIVE statement in config.sys? If not use sysedit to insert a line as follows: LASTDRIVE=G

Some will tell you to use Z as last drive. However, there is no need for this unless you are on a network with many mapped drives. Each drive letter uses a small piece of memory. So only use what you need.

Cumbo
0
 
arunmCommented:
I dont think its a "last drive" problem as the drive is visible in DOS.
0
 
j_powersCommented:
The Last Drive statement is a valid one in this case. Windows 95 treats drives differently in DOS simply because what Win95 needs to install after the Autoexec.bat or Config.sys load - Win95 then loads up the System.ini and Win.ini, which can knock the CD-Rom out, as well as any other 'Real Mode' driver. Try the last drive option setting it 2 drives past the last one (in this case, last drive=h).

Also Do not overlook the obvious. Double check the jumper settings on the drives. If the cable select option is set, try disabling it. Devices on one IDE cable work as fast as the slowest device, so I would suggest to have the HD's on one cable, and the CD rom on another. Then double check the BIOS. Have the BIOS autodetect the CDrom. I have seen CD-roms disabled in BIOS, and then detect because of the 'Real Mode' drivers.

Finally, in Win95, remove the CDrom in the Device manager, and reload the drivers. If this is a brand name CD-ROM, go up to the web and get the latest drivers for it.

If this CD rom is not an old 2-4 speed, and is Win95 compatable, then you will have access to your CD rom in the end.
0
 
rmarottaCommented:
Luby,
This is not an IDE drive.  Forget about connecting it to an IDE port.  As I said earlier, it uses a Sony proprietary interface.  Try this:

1) Disable the MSCDEX statement in your autoexec.bat file.
2) Re-boot the computer into safe mode.
3) Go to Device Manager and check that only one CDROM controller is listed.  If more than one is listed, remove all.
4) Restart Windows normally and re-install the proper controller if necessary.

Is the Sony CDU33a now listed in Device Manager, under it's controller?
Is the drive visible in Explorer now?

Ralph
0
 
LubyAuthor Commented:
I know the drive is not IDE as you say. Sit tight until I try the latest suggestion.

0
 
rmarottaCommented:
Luby,
Any progress yet?
That incorrect proposed answer will be auto-graded if you do not respond.
Regards,
Ralph
0
 
LubyAuthor Commented:
Sorry I took so long to repond.
0
 
rmarottaCommented:
Luby,
The proposed answer has nothing to do with your problem, and should be rejected.
Earlier, you said:
  > "I'll let ya'll know what happened later." and:
  > "Sit tight until I try the latest suggestion."
Do you still need help with this problem?
Regards,
Ralph

0
 
rmarottaCommented:
Well it finally autograded......
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.