Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Num Lock key upon startup

Posted on 1998-10-05
8
Medium Priority
?
318 Views
Last Modified: 2013-12-28
I have an NT Workstation when it boots up it always has the Num Lock key by default.  We had a computer store take the machine to work on it and when it came back the Num Lock key does not stay on by default.  How do I change it so that I don't have to press the Num Lock key every time I start the computer!
0
Comment
Question by:fancy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 2

Expert Comment

by:G0LIATH
ID: 1793326
You should find this option in your BIOS.
Check it out and if you can't find it let me know.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1793327
G0LIATH, BIOS didn't help, 'cause NT has its own opinion how
to set NumLock.

Following works (sometimes):

  login as user
  switch on NumLock
  logoff (not shutdown!)

If you use server-based profiles (ntuser.dat), make shure that
you have a connection to your DCs.
0
 
LVL 9

Expert Comment

by:Koen
ID: 1793328
Fancy, I might be able to help. reject the answer if it's not helping
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 3

Expert Comment

by:cbo120897
ID: 1793329
Hi,
the following registry-entry sets the numlock on at every startup:

find
HKEY_CURRENT_USER\Control Panel\Keyboard
and change the InitialKeyboardIndicators value from 0 to 2


0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1793330
cbo, sound that this is the same as my suggestion ;-)
0
 
LVL 9

Expert Comment

by:Koen
ID: 1793331
Of course, you have to change in the HKEY_USERS/.DEFAULT also if you want it to change it also at logon !!!
0
 

Author Comment

by:fancy
ID: 1793332
This workstation is connected to a NT Server that runs a login.bat
The num lock will be on while the computer boots up but as soon as
the user logs in it goes away!
0
 
LVL 9

Accepted Solution

by:
Koen earned 150 total points
ID: 1793333
OK, if you are not working with mandatory profiles, changing the registry for the user should do the trick.  Of course this would have to be done for every user. If you really need for everyone just make a batch file in the login script setting the above registry in the current user.  To make sure that also new user get the numlock on, change it also in the default user.

If you are using mandatory profiles, just edit the profile !
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configuring Remote Assistance for use with SCCM
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question