• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 216
  • Last Modified:

Move docs into folders of mail archive database

I have the following problem:

In my Mail-database I set up various folders, where I move the incomming mail and a copy of the sent mail, in order to keep the overview.

Now, when I archive a document from one folder, this document is copied into the Archive Database, but only visible in the view "All Documents" The other folders in the Archive Database are all empty.

What am I doing wrong??
0
thommy031498
Asked:
thommy031498
1 Solution
 
PsychoEfferCommented:
You are doing nothing wrong.  I am assuming that you are using a release of Notes prior to 4.5x.  In 4.5+ that problem is fixed....

However, when we upgraded to 4.5, we ended up having to change the mail template so that archiving to folders could be avoided.  We discovered that if one were to attempt to archive mail into the folder in which it belonged, it would usually take more than a minute FOR EACH PIECE OF MAIL!!!  This problem is supposed to be fixed in release 5 of Notes
0
 
ShirishCommented:
Another option, although slightly more time consuming, would be to cut all the documents from a particular folder and paste them in to the appropriate archive database folder. I find that more controlled !
0
 
thommy031498Author Commented:
We are using Version 4.51, and it does not work
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
PsychoEfferCommented:
There may be a problem with the design of your mail file.
I would suggest replacing the design of your mail file, making sure that you choose the appropriate template.

File->Database->Replace Design, for template server choose your mail server, select the Mail (R4.5) template and click Replace.
0
 
PsychoEfferCommented:
BTW...

I have seen people corrupt their archives by cutting and pasting.
0
 
dbrianCommented:
When you archive the documents, you must check the option: "Create new folder" and give the new folder name or select the destination folder .  Otherwise, it will place all the selected documents in the "All Documents" folder by default.
0
 
thommy031498Author Commented:
Where must I check the option "Create new folder" ?
I am using Version 4.5
0
 
TeradCommented:
There is nothing wrong with what you are doing.  I would assume that you are moving the mail from your main mail db to an archive db.  This assumption being correct, then the reason it is happening is because when you archive the mail in your mail db it is sorted into folders.  When you move them into your Archive DB they are NOT sorted.  It's a different Database!  They are sorted into folders in one they are not sorted into folders in the other.
0
 
thommy031498Author Commented:
See comment of Oct. 26
0
 
cwalterCommented:
The problem is that your using the default Notes archive tool which comes with Notes. This tool does not maintain your document sorting when archived. You would need to do it manually or better yet , just write an agent that does what you need it to do and your problem will be solved. The agent that comes in the mail database design doesn't do what you want to do, so you must write the agent.

The simplest would be to create an agent that would copy the document to another databse which is a copy of the original.

1. Create a copy of your mail database
2. This new copy is now your archive DB.
3. Create a new agent in your mail DB that will copy documents older than however long you like to your archive DB.

Thats all.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now