Solved

mouse problem at xwindows in slakware 3.5

Posted on 1998-10-07
10
212 Views
Last Modified: 2013-12-15
i use slakware 3.5 but cannot use mouse in x windows. help me please
0
Comment
Question by:mujdat
  • 4
  • 2
  • 2
  • +2
10 Comments
 
LVL 1

Expert Comment

by:pestilence
ID: 1631011
Thats propably because you haven't setup correctlyyour mouse...try running xf86config and in the mouse area decalre your mouse...if it is a com1 mouse use /dev/cua0 if it is a PS/2 then add the PS2 support...
If the problem is more complicated please send the whole part of it :)
For instance do you have a mouse in command line???
 
0
 

Author Comment

by:mujdat
ID: 1631012
thanx . i will try and inform u about the situation

0
 

Author Comment

by:mujdat
ID: 1631013
my mouse is not PS/2. and use com1 (/dev/tty00) it is still not working.is it have to be /dec/cua0 ?
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1631014
do you have a link  /dev/mouse  to /dev/tty00 ?
/dev/cua0  is not the right one.

Also check if you have gpm running, if so, kill it before starting X.
0
 

Author Comment

by:mujdat
ID: 1631015
there is link but
gpm is running. why do i have to kill it before starting X ?
if i kill it will it work ?

0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Expert Comment

by:tunct
ID: 1631016
normally, gpm should cause no problem... does a text cursor appear when you move the mouse in console mode? does /dev/mouse really point to /dev/ttyS0? do you have a (pnp) modem that might interfere?
0
 

Expert Comment

by:tunct
ID: 1631017
normally, gpm should cause no problem... does a text cursor appear when you move the mouse in console mode? does /dev/mouse really point to /dev/ttyS0? do you have a (pnp) modem that might interfere?
0
 

Author Comment

by:mujdat
ID: 1631018
when i killed gpm mouse worked in X Windows. but i can not write anything at xterm windows this time. what shold i do?
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 0 total points
ID: 1631019
killing gpm solved the problem.

Xterm is a new one. Give more details, best in a new question :-)
0
 

Expert Comment

by:plush98
ID: 1631020
I'd suggest modifying /etc/rc.d/rc.local (or whatever the path is) removing one of the parameters for gpm does the trick... I guess it was -R

0

Featured Post

Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

Join & Write a Comment

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now