Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 155
  • Last Modified:

Problems with the release version.

I have made an application on VC++4. The debug version works fine, even on some machines it gives a "Failed to create empty document" message but it still fine. The matter is when I am Builiding the Release version the application can't run and it gives access violation error.
I think this problem can be correlated with "Failed .." message.
Any ideas?
m3
0
m3
Asked:
m3
1 Solution
 
plarocheCommented:
The usual Release bug comes from unitialized variables. The compiler sets all your variables to zero when you declare them in debug mode, in release it doesn't.

Add debug info to your release build, check the call stack and check for unitialized variables.  To add debug info:

1) Under project settings - C/C++ - General. Select Program Databse from the combo about debug info.

2) Under project settings - Link - General. Check the box for generate debug info.

Find those things can be tough.
0
 
m3Author Commented:
It still doesn't work. All the warnings I have, concerne an unreferenced formal parametres, which I guess doesn't effect much.
m3.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now