Solved

setting up HD

Posted on 1998-10-08
41
228 Views
Last Modified: 2010-08-05
Need help, I just replaced the MB and HD,(award bios
v4.50g)
both are used (not new), the hd is from my old Compaq, The guy that took it off the Compaq said win95 and everything is still on it, I don't know.
I tried to use the win95 set up disc, "can't install win95,
computer does not have a HD, your HD is not funtioning correctly, or your HD requires a special device driver".

The HD is a Quantum. I had that HD replaced with a bigger Quantum a year ago, so I have a flopy disc that came with the bigger Quantum, "ontrack disk manager", if it is of any use.

Do I need to config the HD with award bios before it will work? Do I have the ribbon turned wrong way?

I want to do this now, that computer is setting next to this one, that computer is a no name, compaq has nothing to do with this.

so please don't answer if you're leaving soon, thanks.
0
Comment
Question by:Q98
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 20
  • 10
  • 6
  • +3
41 Comments
 

Author Comment

by:Q98
ID: 1126444
At start up, award lists drive A: 3 1/2,  and B: 5 1/2,
Pri. master disk: chs, mode 0, 1079MB

This HD is about 500MB.

0
 
LVL 2

Expert Comment

by:ViperOne
ID: 1126445
On the HDD, move the jumper from CS (cable select) to master (or slave, depending on your config)

kind regards,

Simon, MCP
0
 

Author Comment

by:Q98
ID: 1126446
When it was on computer before, it was the only HD, shouldn't it already be set?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Q98
ID: 1126447
Jumper is on CS, but the other two are DS ans SP, which one is master?
0
 

Author Comment

by:Q98
ID: 1126448
assuming you are too busy or gone offline, I'm waiting for an answer.
Open to some one else.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126449
CHS and mode 0 sounds wrong if you've just got the drive about a year ago.  Does you IDE cable only has 1 connectors or 2?  The HDD should connect to the connector closest to the motherboard connector.  Also, move your CDRom or whatever you might have to secondery IDE channel, leaving only the HDD on primary.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126450
Oh, afterward, go into your Cmos and try autodetect the drive.
0
 
LVL 3

Expert Comment

by:arunm
ID: 1126451
have you run the detect hard disk utility in the bios? This utility needs to be run to detect the hard disk size and type before the disk can be used.


0
 
LVL 9

Expert Comment

by:larbel
ID: 1126452
Oh, afterward, go into your Cmos and try autodetect the drive.
0
 

Author Comment

by:Q98
ID: 1126453
IDE cable-the flat ribbon?
It starts at the cdrom, then to HD, then to MB.
I didn't just get HD a year ago, i had it replaced a year ago, it came from a compaq 486,
don't know exactly how old it is, maybe 2 or 3 yrs old.

This MB came out of another computer, it's HD is about 1079MB.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126454
So you have 2 HDDs?
0
 

Author Comment

by:Q98
ID: 1126455
No, I have not run detect hard disc, that's what I asked in 1st Q, now I got the HD pulled out to look at the jumpers .
Before I put it back in , Do I have jumpers right??? comments above.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126456
Do you have any extra IDE cable? (the flat ribbon), if so, move the CDRom to another cable leaving only the HDD on the first cable and retry.  There're another connector next to the one the HDD is connecting to, you should connect the CDRom with another cable there.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126457
Leave the jumper as it is, CS is fine.
0
 

Author Comment

by:Q98
ID: 1126458
I do have 1 extra IDE cable, I'll do that.
Only 1 HD going in this computer
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126459
Let me know, if it works, I'll repost it as an answer.
0
 

Author Comment

by:Q98
ID: 1126460
How do I know which side the #1 pin red side goes on HD?
0
 

Author Comment

by:Q98
ID: 1126461
This extra IDE cable has a hole blocked off on both ends, will not go on MB,
is it the wrong cable?
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126462
Check on the outer rim of the connecter, it should have 2 markers to indicate the top.
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126463
Is the cable the same width as the working one?  Watch for the direction it's going in the motherboard.  If it still won't go in, try it without the CDRom first, then you might have to buy another cable...
0
 
LVL 9

Expert Comment

by:larbel
ID: 1126464
I'm answering since I'm now logging off...  I haven't hear from you since my last post I assume it worked...
0
 

Author Comment

by:Q98
ID: 1126465
I went to get a new cable, back now got it on, don't leave yet.
0
 
LVL 2

Expert Comment

by:Hippy
ID: 1126466
Follow these steps and you should be in business,

1). Set the jumper to DS, this is master (SP is Storage Position)
2). Put the drive back as it was, closest to the motherboard, with the CD on the last connector, away from mother board.
3). Red side of ribbon cable goes to the side closest to the main POWER cable.
4). Press delete at bootup to get to the 'CMOS Setup Utility', diferent key on some boards, run the hard disk autodetect.
5). Save and exit the CMOS setup program.
6). Reboot your working (hopefully) machine.

Have fun.

Hippy.
0
 

Author Comment

by:Q98
ID: 1126467
Hippy,
Thanks, I'm at the HD detection now,
I don't get what I'm suposed to do here,
it has under options; 1(y) ...so I hit y, now y is blinking,
everything else -  Size, cyl, head, ect. is 0, at the end is Normal

0
 

Author Comment

by:Q98
ID: 1126468
Ok, I get it now,
do I have to do this for cdrom too?
I left jumper as it was CS, and got a new cable for cdrom.
0
 

Author Comment

by:Q98
ID: 1126469
after detection it still did not list HD,
I changed the jumper to DS as Hippy said,
detected again, It works!!! Win95 is still there.

Hippy, repost as an Answer.
0
 
LVL 2

Expert Comment

by:ViperOne
ID: 1126470
Pfff,back online now (gotta do some work too!)

Guess I'm not eligable for the points anymore now?
0
 
LVL 1

Expert Comment

by:danpaul091498
ID: 1126471
Your problem may not be the HD but the drive. This may be in accurate, but if the disk is older, it may work only with a COMPAQ bios. The reason for this is that Compaq uses a slightly different command set on its drives to prevent you from doing this. Some propietory products will not work on clones. If you have Compaq drive usually it has to go with the BIOS it was shipped with. Get another drive and see if it works. You would have the same problem with an older Conner's drive if it was the slave off a newer ATA/2 drive. That's my opinion.
0
 
LVL 1

Expert Comment

by:danpaul091498
ID: 1126472
Sorry. I misread your reply. Ignore what I said. But that's strange. I had a drive that did that. You could identify, but it wouldn't work with the DS jumper.
0
 
LVL 2

Accepted Solution

by:
Hippy earned 150 total points
ID: 1126473
Just a re-post of my above comment (good to see you got it going)

Follow these steps and you should be in business,

1). Set the jumper to DS, this is master (SP is Storage Position)
2). Put the drive back as it was, closest to the motherboard, with the CD on the last connector, away from mother board.
3). Red side of ribbon cable goes to the side closest to the main POWER cable.
4). Press delete at bootup to get to the 'CMOS Setup Utility', diferent key on some boards, run the hard disk autodetect.
5). Save and exit the CMOS setup program.
6). Reboot your working (hopefully) machine.

Have fun.

Hippy.
0
 

Author Comment

by:Q98
ID: 1126474
Hippy,
I pulled out the 5 1/4 drive, and now the 3 1/2 doesn't work.
They were both using the same cable,
win95 still sees both in explore, but says "not acsesable",
how do I get the 3 1/2 back?
0
 
LVL 2

Expert Comment

by:Hippy
ID: 1126475
Okay,

Floppy drives normaly work like this:

Drive A: is at the far end of the cable (away frome the motherboard/controller)
Drive B: is at the middle of the cable
There is usualy a few wires twisted around between A: and B:, so if the cable has a twist in one end make sure that end is at the drives, not the motherboard.

If the 5 1/4 was drive A:, then move the 3 1/2 to the end of the cable if the cable permits.

You will also have to tell the BIOS that it only has the one drive now, do this from the CMOS Setup program, it should be in the first menu. Turn off the drive that is no longer present, also, if you moved the drive's position on the cable, make sure the size is set right.

Also, double check and make sure you havn't pulled a cable be accident.

Hippy.
0
 

Author Comment

by:Q98
ID: 1126476
This is how it was; 5 1/4 was at the top, then 3 1/2 closest to MB,
I never touched the cable on the 3 1/2, should 3 1/2 be at the end of the cable?

I looked through the BIOS (award), did n't see anything about floppy drives,
is it called something else?
0
 
LVL 2

Expert Comment

by:Hippy
ID: 1126477
Floppy drives should be in the first menu on the left hand side of the CMOS Setup program (Award), tell it drive A: is 1.44, B: is not installed, and make sure the drive is on the end of the cable, leaving the empty connector in the middle.

That'll get you up and running.

Hippy.

0
 

Author Comment

by:Q98
ID: 1126478
since 5 1/4 was the end, the last connection is different, it's more like a slot,
guess I'll have to get another cable.
 
The power on the 3 1/2 is different too, smaller, 4 prongs sticking out of 3 1/2.
Does that Only go on one way?
0
 

Author Comment

by:Q98
ID: 1126479
Still says "floppy disks Fail (40)"
0
 

Author Comment

by:Q98
ID: 1126480
In the "BIOS Features setup" there's "swap floppy drive - Disabled"
is that anything?

is there a way to make it check ram only once, it checks it 3 times.
0
 
LVL 2

Expert Comment

by:Hippy
ID: 1126481
You wen one menu to far, the floppy types are set in:

"STANDARD CMOS SETUP" and are just below the Hard Disk settings. Looks like this:

Drive A  : 1.44,  3.5in.
Drive B  : None
Floppy 3 Mode Support  :  Disabled

most modern floppy cables have five connectors, two slot type, and three pin type (one of wich goes on the motherboard/fdd controller). You may need a new cable.

For the meantime, leave the drive as it is on the middle connector, set bios drive A: = none, b: = 1.44, 3.5 in. in "Standard CMOS Setup"

And enable the "Swap Floppy Drive" setting in "BIOS Features Setup"

To stop the memtest from happening 3 times, enable "Quick Power On Self Test" in "BIOS Features Setup"

Hippy.

0
 

Author Comment

by:Q98
ID: 1126482
OK, done that, no error, starting up it shows drive A-none,
drive B- 3 1/2 , but win95 still shows A as the floppy, no B.
0
 
LVL 2

Expert Comment

by:Hippy
ID: 1126483
Good, that's what's meant to happen.

This is because you told the machine it has no A: but does have a B:, these are the phisical drive positions on the cable.

You then told it to swap it around, so now you have your A: as a 1.44 (3.5in.) and no B:, this is good and the way it should be.

Glad to help, now I'm off to bed. 3:00am / Australia.

Hippy.
0
 

Author Comment

by:Q98
ID: 1126484
Thanks for all the extra help!
I dont know why A still doesn't work, still not accesable,
 I right clicked it in "My Computer" and it locked up.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
On Beyond Tools A conversation I recently had with the DevOps manager of a major online retailer really made me think about DevOps monitoring tools (https://www.onpage.com/devops-incident-management-tool/). The manager and I discussed how sever…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question