Word malfunction in domain

We´re running an NT Network with one NT 4.0 PDC and 50 NT Workstation clients. When logged on with normal user rights, the grammar section in the "options" menu of MS Word 97 is blocked. The checkbox "check grammar together with spelling" is marked, and starting the spellcheck results in an error message conveying that the memory is insufficient to execute the application. When logged on as domain or local admin, everything works fine and the grammar options are accessible. The autocorrect function, however, works properly at all times. Hardware problems can be excluded, since we´re operating ten similar networks on exactly the same hardware at other locations.
Reinstalling MS Office, creating a new user, deleting all policy files and all default user.dat files has not solved the problem. We thought the problem might be the size of the registry file, but we coudn´t explain why the grammar options are blocked, since there is no policy and no specific registry key for such an option. Since the OS was installed by a private company and the server may have been tampered with, we cannot reconstruct all changes that have been made to the server. Reinstalling the OS on all clients and the server would be quite laborious since some of the clients are also clients both for our mainframe as for old UNIX servers.
What can we do?
CaptainFutureAsked:
Who is Participating?
 
Tim HolmanConnect With a Mentor Commented:
Captain,
  Try another approach...
  Backup the registry.
  Delete the keys :
 HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\Grammar\MSGrammar
  HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Proofing Tools\Grammar
  Remove MSGREN32.DLL and MSGR_EN32.LEX from Program Files\Microsoft Share\Proof
  Fire up Word - the Grammar section should now be greyed out because it's been removed...
  Then - put the MSGR* files back into Proof, restart Word.
  Word will update the registry as it fires up and reinstall Grammar.
  It shouldn't be greyed out any more !
  I've just tried it on mine - it works, and it recreates registry entries.
 
Tim
0
 
waynebCommented:
If this is a network install then it appears to be a file rights problem, admin has rights to the shared files and the users do not have the right to read from the install point. The same thing will occur on an Netware server after doing an install from the server. Double check all user file rights.
0
 
Tim HolmanCommented:
Hi,
   I can recreate the problem by removing MSGREN32.DLL from
C:\PROGRAM FILES\COMMON FILES\MICROSOFT SAHRES\PROOF.
   This is the DLL responsible for grammar checking.
   So the problem could be any of the following :

* File permissions on this file
* Maybe it's in a directory that it shouldn't be
* Maybe the system is picking up another MSGREN32.DLL from somewhere else
* Maybe the registry keys are pointing to the wrong place -
HKLM\Software\Microsoft\Shared Tools\Proofing Tools\Grammar is a section I found relating to the location of this file, or just do a search on MSGREN32.DLL to find out what's happening.
* Note that HKLM wouldn't have changed by using your above methods of reinstalling MS Office, deleting USER.DAT etc...

Hope this helps,

Tim
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Tim HolmanCommented:
Damn.  Maybe I should get a spell checker for myself !
0
 
CaptainFutureAuthor Commented:
We have checked file permissions on the workstations, but the users were granted full rights to all files and folders in question.
We tried to restrict the permitted size of the registry file, but again without success.
Next we integrated a new workstation we had installed fom disk into the network. Using a previously unused profile, everything worked fine. When we tried to run one of the other user profiles up to then used on the other machines, we were again unable to access the grammar options in Word97 and the spellcheck gave "not enough memory errors".
When we tried to use the profile that worked on the new workstation on one of the old ones, we had the problem, too. It still works on the new workstation, however.
All registry keys pertaining in any way to the grammar check in word are alike both on the old and the new workstations. The files in the grammar and spellcheck folder all result unchanged since 1996.
So far all we know is that it works using new workstations and new profiles, i.e. starting from scratch.
We don´t know what the heck is going on.
0
 
CaptainFutureAuthor Commented:
We have already tried to undo all policy changes, but we actually found neither a policy nor a registry key that gave us the possibility to grant or prohibit access only to the grammar section of the word options menu
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.