cd-rom problem

windows will not recognize my cdrom. it will only reecognize it if i go to windows reboot to dos and run the cdrom driver disk and return to windows95. then when i boot again i have to do it all over again. any sugestions?
mrdestructAsked:
Who is Participating?
 
OttaConnect With a Mentor Commented:
> it will only reecognize it if i go to windows
> reboot to dos and run the cdrom driver disk
> and return to windows95. then when i
> boot again i have to do it all over again.
> any sugestions?

Running the CD-ROM driver disk adds lines to 'AUTOEXEC.BAT'.
If the lines are added *AFTER* the line which invokes WINDOWS,
then those lines will be executed *ONLY* after exiting
from Windows.

Move the lines to *PRECEDE* the line which invokes Windows.

Show us your 'AUTOEXEC.BAT' file, too.
0
 
mrdestructAuthor Commented:
Edited text of question
0
 
mlaiosaCommented:
add you cd-rom driver to you autoexec.bat/config.sys


your config.sys file probably already has a line that looks somwhat like this:

devive = \somedir\somefile.sys /d:mscd000

you need to copy the line in you \windows\dosstart.bat file that reads somthing like:
mscdex /d:mscd000

into the last line of you autoexec.bat


Thisis not the best solution but the easyest.
0
NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

 
mrdestructAuthor Commented:
i already did this. sorry
0
 
steve06Commented:
When you boot next time, try to let Win95 detect new hardware (Start >> Settings >> Control Panel, then Add New Hardware).

Steve.
0
 
ettieCommented:
Please indicate the age of this CD device as it may not be a plug-n-play device. This will then require the dos drivers to be loaded in order for Windows95 to address the device.
0
 
mrdestructAuthor Commented:
it is a new cd-rom (PnP). 32x i believe. it is very unstable.  
0
 
JBURGHARDTCommented:
windows will detect any cd-rom if  all jumpers  are setup correctly. Set your cd-rom as master on second ide controller (irq15) this will let windows install driver (same for all cd-roms) If you have new system cd-rom should be seen by bios too ( let you boot system from cd-rom windows nt  or most of linux cd-roms)
0
 
mlaiosaCommented:
JBURGHARDT:

Inexperienced moron.  Windows will not detect any correctly configured CD-ROM.
0
 
mrdestructAuthor Commented:
it is set as a slave to the hard drive. it also does not appear in the device manager.t it still works, but it is very unstable.
0
 
leadbootCommented:
Oddly enough I have experienced this problem myself...

Autoexec.bat
Place this line before your sound card line...
LH /L:1,22880 C:\WINDOWS\COMMAND\MSCDEX /D:MSCD001 /M:8

It may need to vary a little but, it worked for me!

0
 
mlaiosaCommented:
it will be more successfull if you make it read more like:  LH C:\WINDOWS.......... without the /L:1,22880       That argument tells LH where in memory to load mscdex and may be spcific to each motherboard/bios design.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.