Solved

Winat scheduler problem

Posted on 1998-10-19
18
1,189 Views
Last Modified: 2013-12-28
I'm trying to run a daily archiving routine using Winat.  This involves copying files from a Novell network onto a local hard disk.  However, I keep getting an "Access Denied" error message.  My account has administrator rights to the network and I've changed the "Log on As" option in Control Panel, Services, Schedule to my account but still no joy. The  command I type at the Winat command line is: C:\winnt\system32\arc.  ("arc" is the name of my archiving batch file.)

Any ideas why access is still denied??
0
Comment
Question by:xander101998
  • 7
  • 7
  • 2
  • +2
18 Comments
 

Author Comment

by:xander101998
ID: 1793849
Edited text of question
0
 

Author Comment

by:xander101998
ID: 1793850
Edited text of question
0
 

Author Comment

by:xander101998
ID: 1793851
Edited text of question
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793852
HI :)

What u can do is that use the net use command at the start of your batch file and then copy the files and then at the end delete the mapping. Here how it goes.

arc.bat

net use m: \\novell\volume\directory password
copy the files
net use m: /delete

Now make sure you must have Client Service for NetWare (Windows NT Workstation) or Gateway Service for NetWare (Windows NT Server) installed and running to connect to NetWare servers.

If it is not the same user name on the netware server then u can use /user:username in the above command to specify other username.

Hope it helps and gives u insight.

0
 
LVL 7

Expert Comment

by:BlackMan
ID: 1793853
If Mujeeb's answer is not working for you, when you say "your account", do you mean the one you are logging on to the system with?
0
 
LVL 3

Expert Comment

by:NullTerminator
ID: 1793854
Sounds like you correctly set scheduler to run under an authorised account, but when you run the arc batch file, are you overwriting existing files on the local hard disk?  Could it be that some of the files you are archiving have the ReadOnly attribute set?  You can't blantantly overwrite them.  Does your batch file copy to a folder?  If so, be sure to include trailing slash character to indicate that this is a folder, not a file.
0
 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793855
Hi :)

Could u please specify the reason for rejecting the answer so that we can help u further.
0
 

Author Comment

by:xander101998
ID: 1793856
sorry mujeeb,

solution worked partially after trying different conbinations of command, but reaches a point when it asks fro a directory password which is non-existant. Leaving out this parameter from the command line results in an "unrecognised server" error message - the server\volume i've specified does,however, exist.
0
 
LVL 7

Expert Comment

by:BlackMan
ID: 1793857
Also check if your account has the Log On As Service privilegde.. (UserManager / Policies / User Rights)
0
 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793858
Hi :)

Can u  map to the directory from explorer or from dos prompt. Also the machine from which u are trying is it winnt server or workstation, and do u have admin right in the machine or not. Also do u have nwlink protocol and the appropiate service installed in case of server or workstation.

Please give informtion and the exact scenario in which u trying to run the commands.
0
 

Author Comment

by:xander101998
ID: 1793859
Hi Mujeeb

In answer to your queries:

- I can map to the dir from Explorer
- my machine is a workstation with admin rights
- csnw loaded and configured

scenario:

i've got an archiving batch file residing on my hard disk (C:\winnt\system32\arc.bat) whose purpose is to copy file from a directory on a network drive to a directory on my hard disk and also to a backup directory on the same network drive.  Currently, running the command "C:\winnt\system32\arc", with the alterations you mentioned made to the batch file, first gives a prompt for a password, then an access denied error message after hitting <RETURN> at password prompt. ( I am already logged on and can see the relevant drive so there should be no need for a password)
0
 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793860
Hi :)

When u just use net use m: <path> to map then NT sends your username and password to the server u are trying to map, if they are the same then it maps and if the user name is the same and password is not then it will prompt u to enter the password. This what happens.

Could u try one thing please. That run the batch file as it is to see whether it goes successfully or not. Remove any mappings if u have and just simulate as it will run under the at command.

If this goes fine then at least it will rule out the possibility of not having enough rights on the source and destination. Also u will come to know that the net use command is mapping the drive or not.

Could u please try the above suggestion and come back with the findings. If the above works fine then the same should work from the at command if u are starting the schedule serive under the same account.
0
 

Author Comment

by:xander101998
ID: 1793861
batch file runs ok locally  without mapping, problem arises when reference to any network drive is made.
0
 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793862
Hi :)

When i said that remove any previous mapping, i meant that u do not map to the directory and run your batch file which has the net use map command and see if it runs fine and connects and backups and disconnects as i suggested before.

If this works then the same should work fine when u schedule it.

If the batch file do not work normaly then please post the error u get at each stage of the batch file.

(I assume u are using the correct frame type since u said earlier that u can map to the driectory and can see the files.)
0
 

Author Comment

by:xander101998
ID: 1793863
batch works fine outside of scheduler, once included in the "at" or "winat" command line it fails to work.  Running it through Winat give the password prompt, then a "system error 5 hs occured" error message after returning through password prompt.
0
 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793864
Hi :)

Is the schedule service is still run under the user account which has access to the directory in the novell. If not then this is the reason why the password does not work. Because NT is trying to connect to the novell directory with the account under which the schedule is running and using the password which is supplied by u in the command (i hope u are not typing password literaly as i suggested before, i meant by password that u enter the password of the account).

Do one thing make the schedule service run under administrator account and change the net use command and add the /user:username with the password. the new syntax would be

net use m: \\novell\volume\directory /user:mujeeb okidoki <- this is the password
your copy commands
net use m: /delete

The above means that when the command will run it will run under the context of the administrator account and will map to the directory using the username and password supplied by u in the net use command. If everything is fine then it should work and u should not have any problem.

Try this and let me know.
0
 
LVL 5

Expert Comment

by:Mujeeb082598
ID: 1793865
Hi :)

Any progress on your side. Problem solved or not.
0
 

Accepted Solution

by:
jancape earned 200 total points
ID: 1793866
Only an account with administrative privilege can start the Schedule service. When you run the Control Panel Services program and set the Schedule service Startup Log On As option to non-administrative, that account does not have Full Control permission on the registry entry below:

   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Schedule

Solution:
Start the Registry Editor and go to the following subkey:

   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Schedule

From the Security menu, choose Permissions. Set Access Type for Full Control on the subkey for the account you tried to use in the Control Panel Services program stated above. The change will take effect once the Schedule service is stopped and restarted.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Storage devices are generally used to save the data or sometime transfer the data from one computer system to another system. However, sometimes user accidentally erased their important data from the Storage devices. Users have to know how data reco…
Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question