?
Solved

auto loop back IP address

Posted on 1998-10-20
5
Medium Priority
?
245 Views
Last Modified: 2006-11-17
I read in a book that setting a link to http://127.0.0.1/cgi-bin/somefile.pl   would allow one to use a perl script locally on a win 95 machine provided that a server soft like Windows personal server and perl were both set up.  I tried this but the script was run without looping back.

The script was:

#!/usr/local/bin/perl
      
print "Content-type: text/html\n\n";

      
print "Worked";

and the call was:  <A HREF="http://127.0.0.1/binvvvv/test.pl">test</A>

where binvvv was the shared directory set up by the server soft.  As I said the script ran( in a ms-dos window) but the info never looped back. Any suggestions?
0
Comment
Question by:guadalupe
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 3

Author Comment

by:guadalupe
ID: 1205549
PS the script runs fine if called in dos but with "perl test.pl"
might be important?

0
 
LVL 3

Author Comment

by:guadalupe
ID: 1205550
pps  sorry but I also realized another detail:

MS Explorer asks me if I want to run the file or save it.  like it doesn´t know what to do with it.  Thats when it runs in the msdos windoe without looping back.  So this is important and the ps added above not so much as the script does get run just not looped back
0
 
LVL 28

Accepted Solution

by:
sybe earned 280 total points
ID: 1205551
make sure that the directory of the perlscript is "executable" (make a virtual directory, and make it executable)

Edit the registry (using regedit)
go to

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3Svc\Parameters\Script Map]

and add

".pl"="C:\perl5\bin\perl.exe %s"

0
 
LVL 3

Author Comment

by:guadalupe
ID: 1205552
Thanks for the suggestion but now the pl script is just oppened as a text document in the browser window, before it was being run (though only in a ms dos window which closed upon completion) and now not even that??
0
 
LVL 3

Author Comment

by:guadalupe
ID: 1205553
Hey just got it to work.  I set the file association in the file type window in Folder Options.  The same association as you stated for the registry.  I don't know why that did it but it did.  Thanks for your help.

Jason
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've just discovered very important differences between Windows an Unix formats in Perl,at least 5.xx.. MOST IMPORTANT: Use Unix file format while saving Your script. otherwise it will have ^M s or smth likely weird in the EOL, Then DO NOT use m…
A year or so back I was asked to have a play with MongoDB; within half an hour I had downloaded (http://www.mongodb.org/downloads),  installed and started the daemon, and had a console window open. After an hour or two of playing at the command …
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
Six Sigma Control Plans
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question