Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 188
  • Last Modified:

"ntbackup" of dir w/ space in name ("program files")

Tell me how I can use the commandline ntbackup to back up just the "program files" directory.  Figuratively, I want to:

ntbackup backup "d:\program files"          /v /d "janelle d:\program files"      /hc:on /t Normal      /l d:\user

Without the quotes around "d:\program files" it tells me I have an invalid parameter (no doubt "files").

With the quotes, it works but backs up "C:" instead of "d:\program files"!

I have tried d:\"program files", but that tells me I have a bad command line parameter too.
0
rclark022197
Asked:
rclark022197
1 Solution
 
gikamCommented:
check the order of parameters
0
 
jminckCommented:
try c:\progra~1
0
 
j_powersCommented:
According to the following keys:

ntbackup operation path [/a][/v][/r][/d "text"][/b
][/hc:{on | off}] [/t {option}][/l "filename"][/e][/tape
:{n}]

You should be able to type

ntbackup backup d:\program files /v /d "janelle d:\program files" /hc:on /t Normal /l "d:\user"

And it will back up the program files. The difference between the two is the quotes in the d:\program files on the path area. Just copy and paste this in your run line.

Good Luck and let me know how this goes.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
rclark022197Author Commented:
I had already tried that.  Per my original note,

    Without the quotes around "d:\program files" it tells me I have an invalid parameter (no doubt "files").
--------------------
0
 
gikamCommented:
rclark,
most probably u are running the command from under a DOS program, such as Norton Commander !
0
 
rclark022197Author Commented:
To Gikam, I am running it under NT's "Command prompt", from which you can type
cd program files
and have it work!
0
 
rclark022197Author Commented:
I would prefer an 'answer' which allowed me to use the long name (program files), but in all fairness jminck solved the problem - his suggestion to use the short name worked.  I assume that the long name would be lost on restoration, but changing one path name is a very small price to pay to have it work!

jminck, if you would submit your suggestion as an 'answer', I will award you the 100 points.  Thanx!
0
 
BlackManCommented:
Your problem is fixed is SP4. The problem is documented in Microsoft KB, http://support.microsoft.com/support/kb/articles/q187/5/19.asp?FR=0
0
 
rclark022197Author Commented:
Thanx!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now