Samba <-> PCs logging on

I could have put this with my other question about Samba but I figured it's a seperate issue.

I have Samba running on RedHat 5.1 on a LAN with several PCs and Macs. I have set smb.conf's "workgroup" setting to the same as all the Win95/98 PC's workgroups, and have checked the "Log onto Windows NT domain" in the Network properties on all the PCs and entered the correct workgroup name.

I have made sure smb.conf has it's "security" setting set to "user" so that people logging on at the PCs use their Linux passwords (in /etc/passwd, yes?) to log in.

Well, it kind of works, except all the PC users are getting error boxes saying something like "No server was found to validate your password. You may not be able to access some network resources"...

But I know for a fact that the PCs *have* found the Linux box because it appears in Network Neighborhood, and people can browse their home directories!!!

Any ideas?
adrianwardAsked:
Who is Participating?
 
talwynConnect With a Mentor Commented:
Samba ... at least the version I have does not mimic an NT domain.  Set the PCs to use workgroups instead.  You can still implement user security since each user has an account.

  The Samba server will act as an NT server on a workgroup but not as a primary domain controller.  Check with the Samba web pages for progress on Samba 2.0 which (I believe) is intended to allow Samba to be a domain controller.
 
              --Steve
0
 
adrianwardAuthor Commented:
But if I uncheck the "Log onto Windows NT Domain" on each PC, then people aren't able to browse each other's machines (nor the Linux machine). It keeps on asking for $IPC passwords... ?
0
 
talwynCommented:
IPC$ shares should be set to guest access, this is how WfW and win95 use workgroups.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
adrianwardAuthor Commented:
I dont understand - what _are_ IPC$ shares? Each user has set sharing full-access on folders on their machines, which in theory should mean that everyone can access them, but when someone else (who doesn't have "Log onto Windows NT Domain" checked) tries to browse these folders, they get password boxes about IPC$ resources. This doesn't make any sense.

Sorry if I'm being a little shortsighted here, but it seems the _only_ way to get Win95/98 networks going properly is to make sure everybody does log onto a WinNT domain... what am I doing wrong?
0
 
talwynCommented:
in the Linux Server smb.conf make sure the following appears in shares:

[IPC$]
  guestonly=yes
  path = /tmp

0
 
adrianwardAuthor Commented:
Thank you for your help. It (kind of) works. PC users can now browse each other's machines, just not the Linux box, but this was not really important - FTP is better for this.

Cheers

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.