• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 216
  • Last Modified:

Winmodem / hardware detection problem

I installed a 56k v90 winmodem and it works most the time.  About every 10-15th time I turn on the computer it will detect a second winmodem and install drivers for it and then neither install will work I have to reboot and take out the second one to use the modem.  I think part of this is I accidentally told windows that part of the sound card on motherboard that it detected were things like PCI bridge so they would not show up under unknown in the hardware manager.  The sound works but I can't get windows to forget what I told it those devices were no matter what I do.  Another thing might be that I have this computer and another conencted with a hub and 3com nics my network works ok but maybe windows thinks the network card is a second modem every now and then?
0
MoonDoggy
Asked:
MoonDoggy
1 Solution
 
uilleannCommented:
Next time kill the first modem and boot
0
 
bushheadCommented:
actually.. what i do is just go to control panel, system and then  press refresh which redetects the modem. all is fine after that. i did something to get rid of this problem but i can't remember right now... sorry

bush
0
 
gauss_lCommented:
I experienced this problem last time. THe easy way out is to reinstall your modem again with the correct drivers.
you should not face anoymore problems

0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
MoonDoggyAuthor Commented:
I have tried this more than once and it does not help, I even have download a few different drivers from 3com/ur thinking maybe the disk was bad.  Another thing I should mention is that this computer boots up extremely fast.  There is a quick boot option in the bios but enabled or disabled windows95 is up and ready after about 10 seconds could that make it not detect hardware right?  Also I think if I could remove the hardware items from device manager that are installed wrong and have it ask me what they should be without just installing the same thing again It might eliminate the problem.  Does anyone know how to make windows forget what a detected hardware item is short of reinstalling windows?
0
 
JustobrienCommented:
Try this to get windows to forget your modem:

Firstly, delete your modem from the Modems option in Control panel.  You should now have no modems listed.  Next, open up explorer and make sure you can see all files by selecting the 'View', 'Options', and 'Show All Files option'.

Now, still in explorer, go to the \Windows\Inf directory and delete the files 'Drvdata.bin' and 'Drvidx.bin'.  What you do next depends on your version of windows -

If you have a subdirectory named 'Other' under the 'Inf' directory then look for files that start with the modem manufacturer's name.  Each of these must be opened, and you need to look for a [Strings] section - If you see your modem listed under there then close and delete the file, if there is no [Strings] section, or your modem isn't listed then check the next file.

If there is no subdirectory named 'Other' under the 'Inf' directory then look for files starting with 'OEM' in the 'Inf' directory, and some numbers after the 'OEM'.  Again, each of these must be opened, and you need to look for a [Strings] section - If you see your modem listed under there then close and delete the file, if there is no [Strings] section, or your modem isn't listed then check the next 'OEM' file.

After doing all this restart your machine, leaving your modem switched on if its external.  The 'Found New Hardware Wizard' should start up, then you need to resupply the correct drivers for your modem and configure it as required.  This way your machine should only recognise your modem once and, hopefully, never again...

0
 
MoonDoggyAuthor Commented:
Thats not the problem.  What Bushhead said is right and it saves me from having to reboot but does not solve the problem.  please please remember what you did because I use this computer remotely and I hate it when I reboot sometimes it detects the modem wrong.  I really think it has something to do with the computer booting up so fast
0
 
bushheadCommented:
hey moon,

i've cracked my head and i think i remember what i did now... i personally don't think it's got anything to do with computer boot up speed.. :) cos this was on my old P133, and that ain't no speed demon!

i did something along the lines of reinstalling. it wasn't the drivers but more along the lines of either IRQ changing or changing the slot in which it resided. it didn't have any conflicts or anything, but if i remember correctly, the modem didn't like sitting with a particular IRQ, so i manually adjusted it and it was happy after that.

hope this works out

bush
0
 
moethecrowCommented:
By any chance is your PC a Dell Optiplex Gxa or newer?  If so I'll have the answer for you as soon as I read my email tomorrow.
0
 
MrStuCommented:
This isn't the proper way to fix this problem but it should get you going.  Next time it istalls the modem go in to the device manager.  Get the properties up for the second modem that was just installed.  Then just disable it in this hardware profile.  There is a little box at the bottom of the general properties screen that you have to check.  This way the OS will see that the device is there it just wont load it.  Reboot and see what happens.
0
 
MoonDoggyAuthor Commented:
moethecrow> answer is no its not a dell
MrStu> I thats one of the first things I tried.  When its thinking there is a second modem it won't let the first modem show up right, it will think the first one is someother device with the wrong drivers installed...  
Bushhead really pretty much solved this, also I figured out on my own how to make windows let me change what a hardware device is
0
 
bushheadCommented:
>Bushhead really pretty much solved this

so have you solved the problem yet?

bush
0
 
lectorCommented:
just disable the "ghost" modem
0
 
MoonDoggyAuthor Commented:
that doesn't work...  Bush just post "text above"  so you can get the credit ;)
0
 
bushheadCommented:
just the posting for the marks..

thanks

bush
0
 
MoonDoggyAuthor Commented:
I think this may have involved the sound card built into the mother board...
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now