Solved

Getting a PNP Network card to work in RH 5.1?!?!?

Posted on 1998-10-23
8
269 Views
Last Modified: 2010-03-18
How can I get my D-Link 220 PNP ISA Network Card to work in RH5.1.
Winbloze 98 shows these parameters for the NIC:
IRQ: 11
Memory Input/Output range: 0240 - 025F
0
Comment
Question by:jboswell
8 Comments
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1587261
Is this isa or pci card
0
 

Author Comment

by:jboswell
ID: 1587262
Edited text of question
0
 

Author Comment

by:jboswell
ID: 1587263
Adjusted points to 80
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 
LVL 3

Expert Comment

by:uilleann
ID: 1587264
Try booting with param: eth0 i=11 a=240
Should force the netcard!
0
 

Author Comment

by:jboswell
ID: 1587265
Since I am fairly new to Linux please explain where to do this.I have gone into the X Control Panel and tried this already to no avail. Please explain.
0
 

Author Comment

by:jboswell
ID: 1587266
I have tried forcing the NIC as proposed to no avail. I even disabled the PNP part of the NIC (Thru a dos DLINK utility) and forced it to IRQ 12 (Since Winbloze had something else assigned to 11 after disabling PNP) and I/O as 240 and still no luck. I keep reformatting my installation of Linux to see if the installation will see the NIC card or not and it hasn't.
0
 
LVL 1

Expert Comment

by:ghjm
ID: 1587267
Boot the machine, wait for the "lilo:" prompt, and try entering:

linux ether=12,0x240,eth0

You have to enter this exactly as typed, with no spaces except for the one between "linux" and "ether" and you have to type fairly quickly or it will proceed before you want it to. If this works, edit your /etc/lilo.conf and add:

append="ether=11,0x240,eth0"    (or whatever command worked)

Then run /sbin/lilo. This will make the command run even if you don't type anything at the boot prompt.

Another way of doing the same thing, if the driver is a module, is to edit /etc/conf.modules and add:

alias eth0 ne    (or whichever module your card uses)
options ne io=0x240 irq=12

-Graham
0
 

Accepted Solution

by:
kidblast earned 80 total points
ID: 1587268
go into your system bios and make make sure it isn't set to boot a plug and play operating system.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question