Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 210
  • Last Modified:

Unattend installation problem

PLease look at the following lines:

\Registry\Machine    (a)
  Software
    Microsoft
      Windows
        CurrentVersion
          Run
            RUNBATCH = REG_SZ "c:\registry\BATCH.CMD"

\Registry\Machine   (b)
  Software
    Microsoft
      Windows NT
        CurrentVersion
          SourcePath = REG_SZ "C:\i386"

\Registry\Machine    (c)
  Software
    Microsoft
      Windows
        CurrentVersion
          SetupSourcePath = REG_SZ "C:"

\Registry\Users    (d)
  Software
    Microsoft
      Windows
        CurrentVersion
          Explorer
            Tips
              DisplayInitialTipWindow = REG_DWORD 00000000
              Show = REG_DWORD 00000000


\Registry\Users    (e)
  .Default
    Control Panel
      Keyboard
        InitialKeyboardIndicators = REG_SZ 2

\Registry\Machine    (f)
  Software
    Microsoft
      Windows NT
        CurrentVersion
          Winlogon
            AutoAdminLogon = REG_SZ 1
            DefaultDomainName = REG_SZ "blablabla"
            DefaultPassword = REG_SZ "xxxx"
            DefaultUserName = REG_SZ "administrator"

When I use this Runonce.ini with (d) at this place,
I have no automatic logon, after the third gui logon I get a logon dialog box, and my numlock is not on.
If I place (d) after (f) I have no problem at all.
What's wrong with the syntax of (d), Do I have to use double quotes around the eight zeroes ?
0
p05010
Asked:
p05010
1 Solution
 
JBirkmannCommented:
Yes you have to use the double quotes around all parameters
0
 
p05010Author Commented:
Explain me why evrything works without the double quotes when (d) is after the last part ?

When I Use         InitialKeyboardIndicators = REG_SZ "2 "
The numlock won't go on at all !!

Bye,
P05010
0
 
dragonfireCommented:
You are trying to put a key under 'users' called 'software'.
Try the correct path:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Tips

Make sure there is no space after the "2" in the 'KeyboardIndicators' bit
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now