Solved

Ctl3d32.dll

Posted on 1998-10-26
15
325 Views
Last Modified: 2013-12-29
Why does my W95 complains that ctl3d32.dll is designed for Nt and is not the right version.
I have copied the dll from the Office97-cd and when that didn`t help i expanded it from the win95-cd to the systemdirectory.
There is only one file on the system and it "lives" in the systemdirectory.
I have scanned the registry and all pointers are to the one and only file on my system.
I am running a centraly installed shared w95 so this problem affects all my 140 users.
0
Comment
Question by:sverre
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +4
15 Comments
 
LVL 14

Expert Comment

by:smeebud
ID: 1726285
If this doesn't do the trick reject the answer please.
-------------
The following tip will help anyone using an older version of Microsoft Office on a Windows 95/98 system (and apparently, there are a lot of you out there!):

"Windows 98 no longer supports the MS-DOS command Share.exe.
But it needs to find that command. Fortunately, the work-around is easy. Open Notepad and save a blank file under the name 'Share.exe' in the Windows System folder (not System32). This 'fake' file solves the problem."

Regards
http://www.geocities.com/~budallen/
0
 
LVL 3

Author Comment

by:sverre
ID: 1726286
Sorry
That didn`t change a thing.
The problem remains.
I am running Office 97 SR-1 and W95 4.00.950 (SR-1 does not support shared installation)
And I know that the ctl3d32.dll is the right version (it might have been wrong) but Windows don`t.
0
 
LVL 1

Expert Comment

by:pctech052197
ID: 1726287
I have had this happen to my system.  MS knowledge base acknowledges the problem:
SYMPTOMS

     When you try to upgrade Internet Explorer version 4.0 to version 4.01, you may receive the following error message:

        This application uses Ctl3d32.dll, which is not the correct version.
        This version of Ctl3d32.dll is designed only for Windows NT systems.

However, it only offers this as a suggestion:

RESOLUTION

     To work around this issue, click OK every time you receive this error message.

     NOTE: You may receive this error message more than once, however, this does not affect the upgrade process.

If you have this version of IE on your systems, maybe try to remove the upgrade on one system, as a test.
It worked on my system, but I went through the trouble of actually removing IE... all of it.
Just backup to be safe
0
MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

 
LVL 3

Author Comment

by:sverre
ID: 1726288
Thank you but I don`t have IE on my system.
The error is exactly the same that you describe, but I recive it when I launch some applications such as Access97.
The application works but it is wery iritating to recive the message, and it indicates that something is wrong.
0
 
LVL 4

Expert Comment

by:NicoLaan
ID: 1726289
Have you tried another more recent version of the file.

You might be able to download an improved version of the dll at microsoft.
Or perhaps some friend has a better one.
Or use sr2 for office and/or windows.

Nico

0
 
LVL 6

Expert Comment

by:sgenther
ID: 1726290
Do you have Foxpro installed?
0
 
LVL 3

Author Comment

by:sverre
ID: 1726291
No, but I have Oracle client 7.3.4.0.0 and Access97
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 1726292
Sverre,
  CTL3D32.DLL is a library of APIs that draw 3D boxes on the screen.
  It imports functions from KERNEL32.DLL, USER32.DLL and GDI32.DLL, so it could also be any of these causing this error.
  As the GetVersion API is imported from KERNEL32.DLL, I think that this is where it may be getting confused.
  How about trying to restore these files just to be on the safe side ?
  What does VER /R tell you about your Win 95 system ?
  Depending on how your shared system is set up - maybe there are some rogue KERNEL32.DLL / CTL3D32.dlls on your workstations, or somewhere in the PATH ?
  If this gets you anywhere, please post up some more details about this problem.

Tim
   
0
 
LVL 6

Expert Comment

by:sgenther
ID: 1726293
Try this....do a file find on Ctl3d32.dll and rename all but the newest one,then try it,if not repeat process until you find one that works.
0
 
LVL 6

Expert Comment

by:sgenther
ID: 1726294
Opps sorry,I see that you have only found one,please reject my answer.
0
 
LVL 6

Expert Comment

by:sgenther
ID: 1726295
I did find this,
The Oracle7 driver is dependent on one additional file that is not
   installed by the Oracle installer setup:
 
      ctl3d32.dll
 
   This file must reside in the C:\WINDOWS\SYSTEM directory. Both Visual
   Basic 4.0 and Visual C++ 4.0 ship with this file.

0
 
LVL 3

Author Comment

by:sverre
ID: 1726296
The most recent version that i have found is 2.29.000
Is there a newer?
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 1726297
Sverre,
  On Win 98 and NT 4 it's version 2.31.000, so as you've said, your file is the correct version !
  What servers are you running ?  NT ?
  Are there any other versions of this file _anywhere_ on your network ?
  I'm sure if you installed everything locally, it would work fine, so there must be something going on with the shared setup.
  In any office applications under the options pull down / tools / file locations... are there any paths there that are wrong, or conflicting ?
  Can you load the correct CTL323D.DLL to your workstations so they pick it up immediately ?

Tim
0
 
LVL 3

Author Comment

by:sverre
ID: 1726298
Sorry that you have been waiting.
I have hade a stomackdisease so i haven`t worked for a wile.
I think i have solved the problem, but people are working here and holding the file open so i have to wait to  the weekend to change the file.
I runned the excelent program "wps.exe" and did find that a file called ctl3dv2.dll was open.
The version of this file is 2.02 and that is an old one. I have found one with version 2.20 and i am planing to use this in my system.
I hope this solves my problem and if it does i thank all people that have tried to help me.
If it not solves my problem i will be back.

If any are interested so am i using Novell NW 4.11 as a serverOS.

\\Sverre
0
 
LVL 1

Accepted Solution

by:
MadCat earned 100 total points
ID: 1726299
This is a know problem to a lot of people.
I had it involving my scanner...
Down this file and you wil be ok....
http://www.cyberramp.net/~chuckw/ctl3d32.exe
Simple as that
it's a selfextracting exe Voila

Have fun regards

MadCat
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A project that enables an administrator to perform actions within a user session context not just at the time of login but any time later on day(s) or week(s) later.
The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question