• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 409
  • Last Modified:

Swap Space

I am running Slackware 3.5

Do any of you have any idea why it says 'Swap size 0' when I enter the command 'free'?  Is it possible that it's not turned on?  
0
ciris
Asked:
ciris
1 Solution
 
frowijnCommented:
look in the /etc/fstab

if there is a option for swap space, it;s there else not !

else you have to make a line in the /etc/fstab like this :

/dev/(your swap device)           swap          swap          defaults      1   1

cheers

Oscar Frowijn

0
 
iceberg102998Commented:
Go into your /etc/rc.d directory and edit the file rc.sysinit.

There should be a line that says
"# Start up swapping
echo "Activating swap partitions"
swapon -a"

if that line isn't there you need to add it, if it is there make sure that your swap partition is listed in /etc/fstab

Hope that helps!
0
 
olvoCommented:
You can type dmesg|more to check if at boot time the system started your swap.
If the swap was activated, but you still read 0, try fdisck to see if the partion is really a Linux swap (I think it shoul be tag 82).
Try to start the swap are by hand, entering the command suggeted above, "swapon -a".
Finally, is your swap is not a Linux type, you can always allocate some of the file system
space to swap, configuring for dynamic allocation, like (forgive me) Windows. Do a man page to see the options

  Good luck
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now