Solved

Link settings problem

Posted on 1998-10-28
8
186 Views
Last Modified: 2013-11-20
Hi everybody!

I'm working with VC5++ prof. edition.
In the link->customize settings the inccremental link option is checked, but the compiler "forget " this any time I build the project. Another problem is, that after compiling, when I try to run the application (no matter if in debug or in release mode), the compiler tell me, that some files (.obj files and the .exe file) doesn't exist, and ask me if I want to build them. If I choose no, and I run tha new .exe, everithyng is fine. This is happen only at two workspaces, which are from another PC.
     HELP!!!!
0
Comment
Question by:visualc
8 Comments
 
LVL 7

Expert Comment

by:psdavis
ID: 1323945
As far as the linker is concerned, I've never had that one.

As far as the compiler is concerned, Cheer up! It's not you.  I get it too.

Phillip


0
 

Expert Comment

by:f4817
ID: 1323946
Hi,

for the compilator alert, have the same trouble. After some research, I can find that when you compil your prog in the small laps of time, the date of some file is not change, and you want to run it's appear older than the source code, so visual ask for build them. I can't find any solution. If you have one, please foward me.
0
 

Accepted Solution

by:
Maizlish earned 50 total points
ID: 1323947
It happenes because the other PC you brought files from has different time and date settings . Be sure to change modificatino times for all the files you brought from that PC.
What happenes is that VC looks at the EXE and object modification times as well as a source code modification times and upon a difference ( positive ) decides whether to recompile and relink the exe.
As i said you can change modification times for the source code by just opennign them and making some change and saving or just "Rebuild all" . To be sure just remove the Release.. and Debug.. directories
0
 
LVL 7

Expert Comment

by:psdavis
ID: 1323948
>It happenes because the other PC you brought files from has different time and date settings . Be sure to change modificatino times for all the files you brought from that PC
 
Nah.. that's not it at all.  It happens all the time since Microsoft went to version 5.  It's got a lot to do with once it compiles, the time that is recorded in the .obj isn't in the past, but the current time.  Then during the compile, it's checking for time LESS than the current time.

Phillip

0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Expert Comment

by:Maizlish
ID: 1323949
VisualC , I am sure that it is the problem (see my answer ) - just reopen the source  files
and save them with your date settings and then rebuild all once .
To see that i am right - you can first change your time settings to match the other computer you brought files from and see what happenes when you just "build".
0
 
LVL 7

Expert Comment

by:psdavis
ID: 1323950
I'm not disagreeing with that fact.  Makefiles have been plagued by the date inconsistencies since the dawn of time.

Visual C 5 and 6 have a NEW problem.  You can be on your own machine and change a file.  Compile the project, it picks up the edited file and compiles it correctly due to the time stamp.  Run the program and it will complain that it needs to compile that same file.  If compiled AGAIN, then it won't complain.  
It's a weird one.  

Of course, we're both just guessing at which one of these situations is his problem at this time.

Phillip
0
 

Author Comment

by:visualc
ID: 1323951
Hi, guys!

  Maizlish have right in my situation. I don't know why, but after the files transfer from the "old" to the '"new" PC, the "Latst Modify" time data of many of this was changed to the next mounth, even if the time settings of the "old" machine was O.K.
  Now everithyng is working fine...
 Thanks for your effort, and if ytou want, send your comments.
After two days I will lock this question giving the point to Maizlish!

  Best regards,   Tibi

0
 
LVL 7

Expert Comment

by:psdavis
ID: 1323952
Maizlish, my fullest apologies!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Introduction: Displaying information on the statusbar.   Continuing from the third article about sudoku.   Open the project in visual studio. Status bar – let’s display the timestamp there.  We need to get the timestamp from the document s…
If you use Adobe Reader X it is possible you can't open OLE PDF documents in the standard. The reason is the 'save box mode' in adobe reader X. Many people think the protected Mode of adobe reader x is only to stop the write access. But this fe…
This video will show you how to get GIT to work in Eclipse.   It will walk you through how to install the EGit plugin in eclipse and how to checkout an existing repository.
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

27 Experts available now in Live!

Get 1:1 Help Now