Solved

IDE HARD DRIVE controler with mind of own

Posted on 1998-10-28
13
234 Views
Last Modified: 2010-04-27
I have a packard bell with the following setup:
The C: (hard Drive) is the bootable drive with win95 on it
The D: (hard drive) is an extra hard drive
The CD-ROM is an ATAPI pioneer 32x drive
C: is hooked into the secondary IDE slot on motherboard and is set by jumpers as master
D: is running from the ribbon that goes to C: and is set as slave by jumpers
CD-ROM is hooked into the primary IDE sslot on motherboard and is set by jumper as master
The problem comes in when win95 starts up... it detects the IDE controller for the CD-ROM but it has the same name as the one for the hard drives... IDE BUS MASTER controller..(something like that)  And !!!IT WORKS!!! All drives work untill the computer is shut down and restarted then the second IDE controller that windows detected stops working and the cd-rom disappears (does not work and completely dissapears from the system device manager
If I delete the conflicting controller and restart the computer it works again.. until I shut it off.... HELP PLEASE why does this happen????
0
Comment
Question by:greatwrym
13 Comments
 
LVL 5

Expert Comment

by:bchew
Comment Utility
Set your CD-ROM to stand-alone instead of master if that setting is available.  If a drive has both, you usually must use the one that applies.  If it ONLY has master and slave but both are configured by closing a jumper, try with both jumpers open.
0
 
LVL 11

Expert Comment

by:RoadWarrior
Comment Utility
I think things might be a darn sight more reliable if you had the harddisks on the primary and the CD Rom on the secondary interface. Master setting is correct for a CD Rom drive as the only device on a cable, having said that, it will usually work as slave too, but can cause the similar sort of problem as above.
0
 

Author Comment

by:greatwrym
Comment Utility
if the hard drives are put on the primary and the cd on the secondary the whole darn thing locks up.... i wish it was that easy... if it was I wouldn't be asking for "expert help".  Thanks for trying.
0
 
LVL 11

Expert Comment

by:RoadWarrior
Comment Utility
ah...
I think you will find you have a fried primary ide interface then. Can you disable it on the board or in bios? if so fitting an i/o card with only the IDE primary enabled should sort that out.

Road Warrior.
0
 
LVL 95

Expert Comment

by:Lee W, MVP
Comment Utility
This could be a driver issue.  Gateway PCs back in early 97 started shipping with newer IDE controllers and installing Win95A or earlier would end up disabling the secondary controller after a reboot.  The only way to fix it, according to Gateway, was to clear CMOS and then immediately install the correct IDE drivers for 95.  

Additionally, I'd swap the hard drives and CD-ROMs.  Generally the primary controller is going to be your PCI based controller and the other controller is ISA based.  Based on that logic, you'll get better performance out of the hard drives on the Primary, especially since the CD-ROM is a fraction of the speed of a hard disk.
0
 
LVL 8

Expert Comment

by:engeltje
Comment Utility
First of all, you will get the best results placing the boot HD on the primary connector. When you do so, things lock up as you said. This can mean that both drives have a different timing. This difference may make the first disk to 'loose' the second from time to time.
Try to connect your bootdisk as master, and your CD ROM as slave to the primary slot. Normally, a CD-ROM can work together with an harddisk better than some harddisks themselve can work together.
Put your second disk to slave, and connect it to the second connector.
Does this work OK?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:greatwrym
Comment Utility
I switched the hard drives... the boot drive is the slave and the other as master I hooked them up to the primary... and hooked th cd-rom to secondary... this worked... backed up the data drive and copied the data to the boot drive and formatted and converted the data drive to the boot drive... this fixed the problem... I answered my question... Shouldn't I get points for that? hahahaha
0
 
LVL 1

Expert Comment

by:billypc
Comment Utility
Please ask the Sys Op to remove your question, now that it has been answered.
0
 
LVL 1

Expert Comment

by:jacobas
Comment Utility
When you tried the cdrom on the secondary, did you go into the BIOS and set the CD as secondary in there?  If not you need to change that in the BIOS!  After that make sure your BIOS are set to boot with the Hard Drive before the CD ROM!  Hope that helps!
Jake
0
 

Expert Comment

by:itzdandy
Comment Utility
i suggest you get a secondary IDE controler, your setup that you said works isn't the correct way to do it and it could damage your drives
0
 

Expert Comment

by:milski
Comment Utility
I need some information to give you the best answer, but consider this some of the older Packard Bell motherboards had problems with putting different types of hard drives together especially old ones with new ones.  That is because of mode at which the drive is accessed at.  Also most of the PBell mother boards where desined to have the hard drives running on the master ide port and the cdrom on the secondary ide port, I am willing to bet that your PBell master restore did not function correctly also.  If you tell me what model you have and the processor and speed of the cdrom orginally installed, along with the FCC ID number of the back of the unit.  I can most likely tell you what type of mother board you have installed and if there are any patches to fix problems like you are describing.
0
 

Accepted Solution

by:
kestrada earned 100 total points
Comment Utility
Turn off the computer open the case and swap the ribbon cables. Connect the hard drives C: configured master and D: configured slave to the primary IDE channel.Connect the CD ROM configured master to the secondary IDE channel.Turn on the computer and go to the CMOS and swap the settings for the primary and secondary IDE channels or use autodetect IDE drives. If there is a boot option select boot to primary IDE. In future provide little more information about your PC. example Model#
0
 

Author Comment

by:greatwrym
Comment Utility
I'm just taking this answer so people will quit answering the question... if you look I answered it myself.... But kestrada said to do what I did so I guess its right... No more answers please I don't need them thanx...
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Is it worth it to buy an Echo? In a word, yes! For me it was definitely worth it. I use mine on a daily basis. Prologue & Privacy At first, I was very skeptical about the Amazon Echo. In general, I don't like voice assistants. I don't li…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now