• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

Win98 never starts the first time

My win98 computer is currently running as perfectly as win98 can. However, to get to this point I have to:
1. Turn it on and let it boot normally.
2. Wait for it to freeze after the splash screen.
3. Turn it off + back on.
4. Let it boot into safe mode. (where it sees nothing unusual).
5. Restart it.
6. Wait longer than I really want to.

My 486 with twice the peripherals and half the ram running linux takes about 1 fifth of this time to boot. And even if it screwed up half the time windoze did (which it doesn't), it would tell me what went wrong. (gratuitous linux plug)
0
ini_7
Asked:
ini_7
  • 6
  • 2
  • 2
  • +6
1 Solution
 
dankhCommented:
Ini,

  Upon seeing "windows is starting" hit the F8 key.  This will give you a run down of what Windows is doing during the boot process.  Pay attention to where the computer freezes up.  I think you might have a problem with one of your drivers/devices.  Tell me what you see.  
0
 
nbdyfoolCommented:
Please tell us what hardware is in the system.  I agree with dankh that it sounds like a device driver or the device itself.  If there is a modem installed, check settings for possible conflicts with Comm ports, i.e. Modem set to Com2, and onboard Com2 is enabled in the Bios, creating a nice little system-halting conflict.  

That's nice that Linux is so informative, but in my experience, Windows (or windoze, as you called it) runs very well for most users, or it never would have gotten to the status it holds now.

0
 
wildagCommented:
I am going to guess that U have a network card in it. I am also going to guess that the system is not always on that network or the network is down. If this is true then I would sugest just to let it freeze. DONT RESTART IT. Just let it go and after about 10 mins it will boot. This should only happen once. It will restart fine from then on.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
ini_7Author Commented:
Okay, this comment addresses all of you. I haven't tried step by step confirmation, but I don't have anything of interest in my config.sys or autoexec.bat. I don't have a modem in this computer, it's in another one that routes traffic to my network. And yes, I do have a netcard. The network's always up, but it's strictly tcp/ip, so I wouldn't imagine there would be any quirks there. I let it stay frozen for about an hour one time (I went out to lunch), and it didn't go anywhere. And in my experience with windows, I can usually get it to do what I want, but it generally takes longer and it's a bigger pain in the ass. And even then it's slower. You're right that for most people it works most of the time, but I put quite a bit of demand on my machines. Also, a lot of the strange problems in this topic are either non existent or easily diagnosed in the unix world.
anyways...

Here's some useful info I got from a bootlog:
[000E45A8] LoadFailed = ndis2sup.vxd
[000E4629] DEVICEINITFAILED    = MTRR    
[000E4778] INITCOMPLETEFAILED  = SDVXD  
[000E47B6] Dynamic load failed  naapi.vxd : [000E47B6] File not found

maybe if I can remove whatever is dependant on these?
0
 
MATTCEICommented:
F8 at 'Starting...',choose '...Bootlog'.After it does its trick,examine the Bootlog.txt file in the root (it's hidden).Look for 'fail's or mis-matched Start/Done s.Hopefully the filename(s) will be informative.
0
 
ini_7Author Commented:
Okay, this comment addresses all of you. I haven't tried step by step confirmation, but I don't have anything of interest in my config.sys or autoexec.bat. I don't have a modem in this computer, it's in another one that routes traffic to my network. And yes, I do have a netcard. The network's always up, but it's strictly tcp/ip, so I wouldn't imagine there would be any quirks there. I let it stay frozen for about an hour one time (I went out to lunch), and it didn't go anywhere. And in my experience with windows, I can usually get it to do what I want, but it generally takes longer and it's a bigger pain in the ass. And even then it's slower. You're right that for most people it works most of the time, but I put quite a bit of demand on my machines. Also, a lot of the strange problems in this topic are either non existent or easily diagnosed in the unix world.
anyways...

Here's some useful info I got from a bootlog:
[000E45A8] LoadFailed = ndis2sup.vxd
[000E4629] DEVICEINITFAILED    = MTRR    
[000E4778] INITCOMPLETEFAILED  = SDVXD  
[000E47B6] Dynamic load failed  naapi.vxd : [000E47B6] File not found

maybe if I can remove whatever is dependant on these?
0
 
MATTCEICommented:
Fastest reply I've EVER seen!

Ndis2sup.vxd is definately a network file.The others I'll have to check on.But before any 'Ah-hah's,compare this to a bootlog created during a successful boot - if they're still there,they're probably unrelated to this error.
0
 
ini_7Author Commented:
Actually that was a prereply that got posted again when I refreshed to look at your comment. I know ndis2sup.vxd is a network thingy, because I've seen it a lot on systems that complain about not being able to find it. (not mine, it's special). But my system runs fine without it. What the hell is it? And yes, that was created during a successful boot. Creating a bootlog seemed to have solved my problem. But it went away for a week one time and came back after a bsOd. I have no idea why, but it would be great to know.
0
 
jagoodieCommented:
When you say "I don't have anything of interest in my config.sys or autoexec.bat" I wonder why you would have anything in these. Do you? Try rem ing everything and see if it works. I agree with the network guys but this may work.
0
 
ini_7Author Commented:
nothing of interest means that I have the following line in my autoexec.bat:
c:\windows\command\doskey
I'll restate the problem: There is nothing obviously suspicious with my hardware. I don't have any conflicts, windows doesn't think I have five of each device, etc. When I turn it on, it starts the splash screen, clears the screen (text mode), and freezes. It's really frozen here, I promise. I reboot it (that's a hard reboot), start it in safe mode, tell it to restart from there, and then it boots with a 40 second delay where it previously froze. I've dealt with a lot of dumb windows problems, but this one is really difficult (or obscure). I'm offering 400 points for a reason, and I'll probably raise that after a while. Feel free to ask technical questions, I am a technically oriented person.
0
 
jagoodieCommented:
have you considered removing the network card to see if that solves the problem? (just software first, then pull the card if the pc still locks up) try adding the software back in, reboot and so on.
I wish you luck.
i just asked about autoexec because i have seen that loading even a cd rom driver can mess up windows.
0
 
jboddyCommented:
Look at:-
http://support.microsoft.com/support/kb/articles/q188/8/67.asp
It covers "Troubleshooting Windows 98 Startup Problems and Error Messages"
0
 
linschotenCommented:
I have had a user with a similar problem in the past.
Goto Control panel - System - Device Manager - System Settings - Plug and Play BIOS - Settings and put a tick by Disable NVRAM / ESCD updates.

0
 
smeebudCommented:
1st, the quick fix:
When errors occur a file called Wnbootng.sts is created in C:\Windows, when restarting computer Win95/98 searches for this file,
if found it will boot in the safemode.

I made a batch file, if you call it then it will delete Wnbootng.sts file.

deltree c:\windows\wnbootng.sts


2nd. If that doesn't do the trick then follow these steps:

When you start your computer, the Windows 95 Startup menu may appear, even though you do not press the F8 key when you see
the "Starting Windows 95" message, and then the following message may appear:

Warning: Windows did not finish loading on the previous attempt.
Choose Safe mode, to start Windows with a minimal set of drivers.

If you do not choose an option, Windows 95 starts in Safe mode by default. This behavior can occur even if Windows 95 started
successfully the last time you started your computer.

CAUSE


This behavior can occur if Windows 95 was unable to delete the Wnbootng.sts file in the Windows folder the last time you started
Windows 95. This file is created each time you start Windows 95, and is deleted after Windows 95 starts successfully.

If Windows 95 does not start successfully, the Wnbootng.sts file remains in the Windows folder and causes the message stated
above to be displayed the next time you start Windows 95. If Windows 95 cannot remove the Wnbootng.sts file, the message
appears each time you start Windows 95.

RESOLUTION


Use Windows Explorer or My Computer to delete the Wnbootng.sts file in the Windows folder, and then restart your computer.

If deleting this file does not resolve the issue, try the following steps.

NOTE: You must have a Windows 95 Startup disk to follow these steps. If you do not have a Startup disk, create one before
following these steps.
To create a Startup disk, double-click Add/Remove Programs in Control Panel, click the Startup Disk tab, and then click Create
Disk.
See "Assorted Categories"
"Rescue Disk That Reads Your CD-ROM"

1. Type the following lines at a command prompt, pressing ENTER after each line:

attrib -s -h -r :\io.sys
ren :\io.sys :\io.xxx

where is your computer's physical boot disk.

2. Insert the Windows 95 Startup disk in drive A.

3. Type the following line, and then press ENTER

a:\sys :

where is your computer's physical boot disk.

4. Remove the Startup disk and then restart Windows 95.

Regards
http://www.geocities.com/~budallen/
0
 
ini_7Author Commented:
And we have a winner! linschoten, please make an answer out of your comment to claim your prize. And to the rest, thank you for your attempts!
0
 
smeebudCommented:
So it boots good, no freeze and no safe mode??

Bud
0
 
ini_7Author Commented:
that's correct. There's still a tad delay, but now it at least boots the first time. It would be nice to have that file removed before it comes up with that menu crap. When I want it to start in safe mode, I'll let it know. I hate how there's no easy way to configure <disable> the dumb things. BTW, reinstalling didn't help, I tried that a couple days after this started happening.
0
 
linschotenCommented:
I have had a user with a similar problem in the past.
Goto Control panel - System - Device Manager - System Settings - Plug and Play BIOS - Settings and put a tick by Disable NVRAM / ESCD updates.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 2
  • 2
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now