Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 235
  • Last Modified:

Problems with network card

How do i find out what address my network card is at?
i have tried autodetecting for the card.
Windoze reports that it's a ne2000 compatible, ISA network card at 0x240, but linux does not find the card at this address. It is a plug n pray card.

Please Help..
0
philalakin
Asked:
philalakin
1 Solution
 
strmtrprCommented:
the card has to be configured before it will work in linux there is a pckage called isapnptool
that will do the trick. you may already have on your system . try pnpdump at the command line.
if you get a long script then you have it.  If not get it

let me know if you need help using it.
0
 
strmtrprCommented:
the card has to be configured before it will work in linux there is a pckage called isapnptool
that will do the trick. you may already have it  on your system . try pnpdump at the command line. if you get a long script then you have it.  If not get it

let me know if you need help using it.
0
 
_HAL_Commented:
First, set the PnP mode of your card to disabled and configure its address manually.

Then... you must compile your kernel with "Compatible NE2000 ISA support" option.

Finally... reboot your machine and good luck ;)


0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
philalakinAuthor Commented:
How do i re-compile the kenel with ne2000 support?
where do i get the extra modules from?
how do i disable pnp?
will this change my windoze settings?
0
 
xtermCommented:
You've probably already got modular ne2k support if its any
recent distribution running on the default kernel.

Just add an append statement to your /etc/lilo.conf right
above the section with your kernel images that looks like:
append="eth=0x240,(irq)" (consult the Ethernet HOWTO on any
linux mirror for the exact syntax, its been a while since
I've used that one...)

Don't forget to run /sbin/lilo after adding that line.
Then reboot & see what happens.


0
 
philalakinAuthor Commented:
I don't use lilo.
I am using loadlin, is there a way to do it using that?

Thanks again

0
 
cwalterCommented:
Switch to /usr/src/linux or where ever your Linux source is stored and run:
make menuconfig
Then add the network suppor that you need.
Save these changes then do a:
make dep ; make clean
then a
make bzImage
then copy the new kernel from
/arch/i386/boot to /
then modify your lilo.conf to point to your new kernel
then run
lilo lilo
and then reboot
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now