• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 381
  • Last Modified:

NE2000 compat no detected

I have installed Linux 5.1 (several times).

Most things go well except the network card installation.  the system reports while trying to install the drivers that the card can't be found in the system.  I've tried 2 very standard ne2000 compatable cards at 320/5 and 320/10 even specifying the settings and no luck(there are no IRQ conflicts, LPT1 is on 7) The same cards installed on DOS or windows machines perform perfectly.


Heeeeeeeelllllppp.  LOTS of points for this one.
0
innovate
Asked:
innovate
  • 3
  • 3
1 Solution
 
innovateAuthor Commented:
Edited text of question
0
 
strmtrprCommented:
is the card PNP.
0
 
mart010897Commented:

I've had this problem before.  What you want to do is recompile your kernel with ONLY support for NE2000.  A lot of times the ne2000 compatible adapter doesn't get recognized if any other driver is present.

Good luck...

Mart
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
innovateAuthor Commented:
How do I recompile the Kernel with support ONLY for ne2000 compatible?

The card is PNP but I have disabled PNP using the card's utility and set 320/5.
0
 
mart010897Commented:
cd /usr/src/linux
make config

in the sections about network cards, answer no to everything but NE2000 support.

If you have never compiled your kernel before, read the docs about it...

A possible alternative is to specify the eth0 properties manually at boot.  do to this, reboot your machine and get to the

LILO boot:

prompt.  Assuming you normally type "linux" to boot Linux,  you'd type:

LILO boot: linux ether=5,0x320,eth0

to specify that you want to detect an ethernet card on IRQ 5, base 0x320.  Give that a shot, maybe it'll work for ya.  If it does, then you can recompile your kernel whenever you get around to it I guess.

Let me know how that works out...

Mart
0
 
innovateAuthor Commented:
Sorry I took so long to reply Mart,

When I boot the system I get a login prompt to which I respond with the root user and my password.  Then I end up at a

[root@localhost /root]#

prompt

None of the above commands result in anything but "no such file or directory" or "command not found"

I have xwindows will that help.


0
 
mart010897Commented:
The LILO boot: prompt is before you boot Linux, right when you turn on your PC.  Assuming you have installed LILO, if you're not getting the LILO boot: prompt, hold down the right Shift key when you turn your computer on to get it.  Then proceed as I mentioned above.

If you don't have /usr/src/linux, then you don't have kernel source code installed, and won't be able to compile your kernel.  Add the "C/C++ Development" packages from your distribution if you have not done so already, then either install the "Kernel Source" package or download kernel source from http://sunsite.unc.edu/pub/Linux/kernel/v2.0
Look at http://sunsite.unc.edu/pub/Linux/docs/HOWTO/Kernel-HOWTO for a guide to compiling your kernel.  If you're interested in Linux, it's something you'll want to know about anyway.

For more information about getting your ethernet card working, look at: http://sunsite.unc.edu/pub/Linux/docs/HOWTO/Ethernet-HOWTO

You can go ahead and reject the answer above, since it didn't solve your problem.

Good luck...

Martin
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now